Bug 503098 - kpackagekit doesn't work with yum-presto
kpackagekit doesn't work with yum-presto
Status: CLOSED DUPLICATE of bug 500428
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 16:25 EDT by Mary Ellen Foster
Modified: 2009-05-28 17:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-28 17:17:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mary Ellen Foster 2009-05-28 16:25:36 EDT
Description of problem:
I use kpackagekit and I have yum-presto installed, and they don't seem to be compatible. I think that all of the deltarpms get downloaded, but then kpackagekit crashes with the following backtrace (sorry for the big blob):

Traceback (most recent call last):
File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 1830, in _runYumTransaction rpmDisplay=rpmDisplay)
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 3653, in processTransaction pkgs = self._downloadPackages(callback)
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 3677, in _downloadPackages probs = self.downloadPkgs(dlpkgs)
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1317, in downloadPkgs self.plugins.run('predownload', pkglist=pkglist)
File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 180, in run func(conduitcls(self, self.base, conf, **kwargs))
File "/usr/lib/yum-plugins/presto.py", line 577, in predownload_hook (problems, more) = downloadPkgs(conduit, pinfo, download_pkgs)
File "/usr/lib/yum-plugins/presto.py", line 419, in downloadPkgs cb.start(text="", size=rebuild_size)
File "/usr/lib/python2.6/site-packages/urlgrabber/progress.py", line 129, in start self._do_start(now)
File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2551, in _do_start self.updateProgress(name, 0.0, "", "")
File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2593, in updateProgress pkg = self._getPackage(name)
File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2534, in _getPackage sections = name.rsplit('-', 2) AttributeError: 'NoneType' object has no attribute 'rsplit' 

I *think* (although I can't guarantee) that this used to work until the most recent yum update ...

Version-Release number of selected component (if applicable):
kpackagekit-0.4.0-7.fc11.x86_64
yum-presto-0.5.0-1.fc11.noarch


How reproducible:
Every time

Steps to Reproduce:
1. Do an update for which drpms are available
  
Actual results:
drpms get downloaded, and then kpackagekit crashes
Comment 1 Rex Dieter 2009-05-28 17:17:12 EDT
PackageKit bug.

*** This bug has been marked as a duplicate of bug 500428 ***

Note You need to log in before you can comment on or make changes to this bug.