Bug 503104 - Yaboot doesn't like root=UUID - Syntax error or read error config
Yaboot doesn't like root=UUID - Syntax error or read error config
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yaboot (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tony Breeds
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 16:58 EDT by James Laska
Modified: 2013-09-02 02:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-16 14:40:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yaboot.conf (425 bytes, text/plain)
2009-05-28 16:58 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-05-28 16:58:03 EDT
Created attachment 345841 [details]
yaboot.conf

Description of problem:

Installing Fedora 11 sometimes results in a system with root=UUID.  Yaboot does not appear to like the UUID string in the yaboot.conf and fails to boot the OS.


Version-Release number of selected component (if applicable):
yaboot-1.3.14-12.fc11

How reproducible:
Not every time ... it's only when yaboot.conf contains root=UUID.

Steps to Reproduce:
1. Install Fedora 11 on an IBM Power5 system
  
Actual results:

Elapsed time since release of system processors: 203130 mins 38 secs

Config file read, 32768 bytes
Config file error: Token is too long near line 0 in file /etc/yaboot.conf
Syntax error or read error config
Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-12.fc11)
Enter "help" to get some basic usage information
boot: 

Expected results:

Successful boot

Additional info:

 * See attached yaboot.conf
Comment 1 Roman Rakus 2009-06-02 08:20:46 EDT
I can't reproduce it on ppc iBook G4. root=UUID=... is parsed well.
I will try to investigate it more...
Comment 2 Roman Rakus 2009-06-02 08:30:52 EDT
For me, this looks like bad yaboot.conf file. Attached file seems to be ok, but is this one really read by yaboot?
Comment 3 Bug Zapper 2009-06-09 12:44:30 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Tony Breeds 2009-06-22 21:05:18 EDT
(In reply to comment #0)

> Installing Fedora 11 sometimes results in a system with root=UUID.  Yaboot does
> not appear to like the UUID string in the yaboot.conf and fails to boot the OS.

I can't reproduce this on the machines I have access to [in fact my Fedora systems all have root=UUID].  I'm tempted to close it, as it looks like a bad yaboot.conf.  Which begs the question how is it getting corrupted?.

Can you reproduce the error with yaboot.debug from:
http://kojipkgs.fedoraproject.org/scratch/tbreeds/task_1431096/yaboot-1.3.14-14.fc12.ppc.rpm

Also what type of filesystem is your /boot?
Comment 5 James Laska 2009-06-23 08:25:33 EDT
(In reply to comment #4)
> (In reply to comment #0)
> 
> > Installing Fedora 11 sometimes results in a system with root=UUID.  Yaboot does
> > not appear to like the UUID string in the yaboot.conf and fails to boot the OS.
> 
> I can't reproduce this on the machines I have access to [in fact my Fedora
> systems all have root=UUID].  I'm tempted to close it, as it looks like a bad
> yaboot.conf.  Which begs the question how is it getting corrupted?.
> 
> Can you reproduce the error with yaboot.debug from:
> http://kojipkgs.fedoraproject.org/scratch/tbreeds/task_1431096/yaboot-1.3.14-14.fc12.ppc.rpm
> 
> Also what type of filesystem is your /boot?  

I'll have to spend some time installing several systems to identify when it fails.  

I suspect the root=UUID in the yaboot.conf isn't to blame, unfortunately it was the only difference between a working and non-working yaboot.conf. 

It doesn't reproduce all the time, it seems specific to the partitioning used.  For example, when I kickstart RAID a Power5 ... I think that was enough to introduce the failure.  

Retesting ...
Comment 6 Tony Breeds 2009-11-25 20:12:32 EST
I think the yaboot in F-12 is okay, so we can close this right?
Comment 7 James Laska 2009-12-16 14:40:57 EST
Good catch Tony, yes we can close this puppy out.  There was another bug related to dracut on ppc in F-12 (which may have been the root cause for this issue).  That problem is resolved.

Note You need to log in before you can comment on or make changes to this bug.