Bug 503112 - gnome-vfs2 webdav dislikes commas in directory path
gnome-vfs2 webdav dislikes commas in directory path
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-vfs2 (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Tomáš Bžatek
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 18:28 EDT by Shawn Houston
Modified: 2015-03-03 17:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-13 07:09:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Houston 2009-05-28 18:28:46 EDT
Description of problem:

Using nautilus to mount a webdav share should work even when there is a comma in the directory path, but instead all access beneath the point of the comma is Empty and a refresh of the directory including the comma says the directory does not exist.

Version-Release number of selected component (if applicable):

gnome-vfs2-2.16.2-4.el5

How reproducible:

every time

Steps to Reproduce:
1. mount a webav share
2. create a folder with a comma in its name
3. try to use the folder
  
Actual results:

Says directory is empty or does not exist

Expected results:

OS X and Ms Windows both can access and use the directory, gnome should to.


Additional info:
Comment 1 Tomáš Bžatek 2009-06-02 06:11:00 EDT
Can you post example of the URI?
Can you try escaping the comma in the URI with something like %2C ?
Does it happen when just browsing the structure - i.e. does Nautilus produce bad URI itself?
Comment 2 Shawn Houston 2009-06-02 08:27:50 EDT
davs://test.server.com/this,path/has/a_comma/in.it

Browsing? nautilus mounts the share in a drive like fashion. With the comma in the path you get an empty directory at a_comma and never see the file in.it at all.

From cursory testing (logs, some sniffing) it looks like nautilus is sending the correct URI with the %2C in it, it looks like nautilus is choking on the server response. I use Apache with mod_davfs, but that should not matter as both OS X and MS Windows do not exhibit the issue using the same server.

You can even use nautilus to add the comma, and as best as I can tell you can still add things to the directory using nautilus, just not see them, and nautilus tells you that a_comma does not exist if you refresh its contents.
Comment 3 Tomáš Bžatek 2009-06-02 09:16:29 EDT
Confirming, reproduced locally. 

Looks like an URI encoding issue, gnomevfs-ls can list the contents in simple form (davs://test.server.com/this,path/has/a_comma/) fine, fails with %2C (which is done by Nautilus automatically).

Fedora 10 and later is fine. Waiting for proper acks.
Comment 4 Tomáš Bžatek 2009-11-23 10:57:38 EST
Particular gnome-vfs2 commit fixing the issue: http://git.gnome.org/cgit/gnome-vfs/commit/?id=c1dc878e453edeff6cb63f655d2a8d70cf7f6418
Comment 9 errata-xmlrpc 2010-01-13 07:09:21 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0032.html

Note You need to log in before you can comment on or make changes to this bug.