Bug 503122 - Partitioner shows non-existent free space
Partitioner shows non-existent free space
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 20:00 EDT by Gary Hade
Modified: 2009-06-02 16:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 16:57:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of partitioner showing free space (63.27 KB, image/jpeg)
2009-05-28 20:00 EDT, Gary Hade
no flags Details
screenshot of partitioner showing add partition failure (64.10 KB, image/jpeg)
2009-05-28 20:02 EDT, Gary Hade
no flags Details
screenshot showing fdisk(1) not finding free space (79.29 KB, image/jpeg)
2009-05-28 20:04 EDT, Gary Hade
no flags Details
logs (31.63 KB, application/octet-stream)
2009-05-29 12:55 EDT, Gary Hade
no flags Details

  None (edit)
Description Gary Hade 2009-05-28 20:00:20 EDT
Created attachment 345848 [details]
screenshot of partitioner showing free space

Description of problem:
See attachments.  Partitioner shows 15249 MB of free space on
/dev/sdc but an attempt to create a new partition using that
free space failed with "Could not allocate requested partitions:
not enough free space on disks error".  fdisk(1) also shows
"no free sectors available" so it appears that the partitioner
is showing free space that does not exist.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Gary Hade 2009-05-28 20:02:21 EDT
Created attachment 345849 [details]
screenshot of partitioner showing add partition failure
Comment 2 Gary Hade 2009-05-28 20:04:54 EDT
Created attachment 345851 [details]
screenshot showing fdisk(1) not finding free space
Comment 3 Joel Andres Granados 2009-05-29 05:36:26 EDT
In your attachments I do not see the 15249 MB of free space you are referring to.  Pls attach a screen shot with the felated info.  Also, It is important to attach also the installer logs for debbuging.  You can find those in /tmp/*
Comment 4 Gary Hade 2009-05-29 11:56:32 EDT
(In reply to comment #3)
> In your attachments I do not see the 15249 MB of free space you are referring
> to.  Pls attach a screen shot with the felated info.

Please look at the "screenshot of partitioner showing free space"
attachment again.  The 15249 MB free space appears on both the
graphical and list descriptions of /dev/sdc.

> Also, It is important to
> attach also the installer logs for debbuging.  You can find those in /tmp/*  

Let me know if you still need this.  I will have to restart the
installation to obtain.
Comment 5 Gary Hade 2009-05-29 12:55:16 EDT
Created attachment 345926 [details]
logs
Comment 6 Gary Hade 2009-05-29 12:59:43 EDT
(In reply to comment #4)
> (In reply to comment #3)
...
> > Also, It is important to
> > attach also the installer logs for debbuging.  You can find those in /tmp/*  
> 
> Let me know if you still need this.  I will have to restart the
> installation to obtain.

Never mind.  I restarted the install, unsuccessfully attempted
to create a partition using the displayed free space, and then
obtained the attached logs.
Comment 7 Joel Andres Granados 2009-06-01 08:52:08 EDT
(In reply to comment #4)
> 
> Please look at the "screenshot of partitioner showing free space"
> attachment again.  The 15249 MB free space appears on both the
> graphical and list descriptions of /dev/sdc.
> 
Aha, gotcha.  Sorry I missed this the first time around.
Comment 8 Joel Andres Granados 2009-06-01 08:57:44 EDT
I see some strangeness in your /dev/sdc that might make anaconda confused.  Do you have the extended partition in /dev/sdc3?  Can you pls attach the out put of `parted /dev/sdc print free` and `parted /dev/sdc unit s print free`?  Does it make a difference if you repartition you /dev/sdc to have the extended partition in /dev/sdc4? (if you can)
Comment 9 Gary Hade 2009-06-01 13:11:53 EDT
(In reply to comment #8)
> I see some strangeness in your /dev/sdc that might make anaconda confused.  Do
> you have the extended partition in /dev/sdc3?

Yes.  I believe the information in the "screenshot showing fdisk(1)
not finding free space" attachment already answered this question.

> Can you pls attach the out put
> of `parted /dev/sdc print free` and `parted /dev/sdc unit s print free`?

NOTE that the following is _after_ installation where the
disk shows up as /dev/sdb.

[root@elm3b55 ~]# parted /dev/sdb print free
Model: IBM-ESXS ST973451SS (scsi)
Disk /dev/sdb: 73.4GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags
 1      32.3kB  21.0GB  21.0GB  primary   ext3         boot 
 2      21.0GB  26.2GB  5240MB  primary   ext3              
 3      26.2GB  42.2GB  16.0GB  extended                    
 5      26.2GB  42.2GB  16.0GB  logical   ext3              
 4      42.2GB  57.4GB  15.2GB  primary   ext3              
        57.4GB  73.4GB  16.0GB            Free Space        

[root@elm3b55 ~]# parted /dev/sdb unit s print free
Model: IBM-ESXS ST973451SS (scsi)
Disk /dev/sdb: 143374000s
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start       End         Size       Type      File system  Flags
 1      63s         40965749s   40965687s  primary   ext3         boot 
 2      40965750s   51199154s   10233405s  primary   ext3              
 3      51199155s   82445579s   31246425s  extended                    
 5      51199218s   82445579s   31246362s  logical   ext3              
 4      82445580s   112133699s  29688120s  primary   ext3              
        112133700s  143364059s  31230360s            Free Space 

[root@elm3b55 ~]# fdisk -l /dev/sdb

Disk /dev/sdb: 73.4 GB, 73407488000 bytes
255 heads, 63 sectors/track, 8924 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0007c6ba

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        2550    20482843+  83  Linux
/dev/sdb2            2551        3187     5116702+  83  Linux
/dev/sdb3            3188        5132    15623212+   5  Extended
/dev/sdb4            5133        6980    14844060   83  Linux
/dev/sdb5            3188        5132    15623181   83  Linux
       

> Does
> it make a difference if you repartition you /dev/sdc to have the extended
> partition in /dev/sdc4? (if you can)

That would be difficult because we already have some stuff installed
on that partition that we would rather not blow away.  It could also
make it impossible for us to continue to reproduce the problem and
test fixes that you may want us to try.
Comment 10 Joel Andres Granados 2009-06-02 06:11:58 EDT
I think I know what is occurring... I think you are suffering from unreachable free space due to your wacky partition table.  No wonder anaconda got confused :)

1. You do have free space.
2. You cant access it by just adding a partition.

Let me elaborate: 
Since there can be only one extended partition in a msdos partition table;  And, you can have maximum 4 primary partitions; And, you have your extended partition in the middle of two primary partitions; And, you have one logical partition that occupies all the space of the extended partition, I really don't see a sane way you can add a partition to your setup.
You need to partition your disk in such a way that, if you are using the 4 primary partitions (note that extended is also primary), you make sure to occupy the whole of the disk.

What you should do to rescue your free space.
A. If you want more partitions, there are two approaches:
   1. You must move the last primary partition to the end of the disk and
      resize the extended partition to fit between the second primary and
      4 primary partition.  After resizing, you must add logical partitions
      to your extended partition.
   2. If there is no important info on the last primary partition, I would
      remove that one and resize the extended partition to occupy the rest
      of the disk.  Then I would add logical partitions.

B. You can also just resize the last primary partition.  But that wont give
   you the opportunity to add more partitions, it will just rescue your
   unreachable free space.
Comment 11 Gary Hade 2009-06-02 16:57:04 EDT
Ahh, I see what you are saying.  That is wacky!  Not sure
how it got that way but it seems unlikely that the same thing would
happen in a sane environment.  Our lab is definitely _not_ that kind of
place.  I think we can close this one as NOTABUG.  Thanks a lot for
looking at it.

Note You need to log in before you can comment on or make changes to this bug.