Bug 50319 - After choosing a custom install it failed.
After choosing a custom install it failed.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 53969 54324 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-30 08:55 EDT by Brad Starkenberg
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 15:44:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Starkenberg 2001-07-30 08:55:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
I tried to install several times using the custom install and it always 
failed at the end saying to save the error to disk and send to bugzilla. I 
have it on a floppy.

How reproducible:
Always

Steps to Reproduce:
1.Attempt to install using custom settings and hda1 is a windows partition.
2.Use a single root partition of 9gb and a swap of 1 gb
3.All atempts like above failed.
	

Actual Results:  Failed to install.

Expected Results:  Successful install

Additional info:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 
19, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1964, in 
doInstall
    self.fstab.write (self.instPath)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/fstab.py", line 885, in 
write
    iutil.mkdirChain(prefix + mntpoint)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iutil.py", line 237, in 
mkdirChain
    os.mkdir(path, 0755)
OSError: [Errno 17] File exists: '/mnt/sysimage/dev/hda1'

Local variables in innermost frame:
which: 5
dir: /mnt/sysimage/dev/hda1
elements: ['', 'mnt', 'sysimage', 'dev', 'hda1']
path: /mnt/sysimage/dev/hda1

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S'1024x768'
p4
sS'progressWindow'
p5
(igui
ProgressWindow
(dp6
S'total'
p7
I907
sS'window'
p8
(igtk
GtkWindow
(dp9
S'_o'
p10

<failed>
Comment 1 Brent Fox 2001-07-30 11:19:09 EDT
At which screen does it fail?  Right before installing packages?
Comment 2 Brad Starkenberg 2001-07-31 08:41:22 EDT
After reaching 100% after installing packages the messge above is given.
Comment 3 Brent Fox 2001-08-06 11:13:42 EDT
Did you set a mount point for your Windows partition?
Comment 4 Brad Starkenberg 2001-08-08 23:48:23 EDT
Yes. Mount point for Windows(DOS) partition was /dev/hda1.
Thanks
Comment 5 Matt Wilson 2001-08-09 15:44:31 EDT
no, that's where the device is located.  You selected the device in Disk Druid
and then assigned its mount point to be /dev/hda1.  /dev/hda1 is a device node,
not a directory.  You should mount it under /dosc or something like that.
Comment 6 Matt Wilson 2001-08-09 17:10:03 EDT
this unhandled exception will be handled in the next release.
Comment 7 Brent Fox 2001-09-24 15:21:02 EDT
*** Bug 53969 has been marked as a duplicate of this bug. ***
Comment 8 Brent Fox 2001-10-04 10:37:48 EDT
*** Bug 54324 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.