Bug 503203 - qspice-libs-devel doesn't pull libXrandr-devel
qspice-libs-devel doesn't pull libXrandr-devel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: qspice (Show other bugs)
5.3
All Linux
high Severity urgent
: beta
: ---
Assigned To: Yuval Kashtan
:
Depends On: 498044
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-29 11:25 EDT by Eduardo Habkost
Modified: 2016-04-26 10:21 EDT (History)
14 users (show)

See Also:
Fixed In Version: qspice-0.3.0-36.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 494249
Environment:
Last Closed: 2009-09-02 06:57:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduardo Habkost 2009-05-29 11:25:10 EDT
THe real bug is bug #494249, but we need to work around it by adding a Requires: libXext-devel to qspice-libs-devel.


+++ This bug was initially created as a clone of Bug #494249 +++
[...]
--- Additional comment from yzhou@redhat.com on 2009-04-28 04:16:56 EDT ---

Another problem, does it also require the 'libXext-devel' package?

# pkg-config --libs spice
Package xext was not found in the pkg-config search path.
Perhaps you should add the directory containing `xext.pc'
to the PKG_CONFIG_PATH environment variable
Package 'xext', required by 'Xrandr', not found

# rpm -qa |grep spice
qspice-libs-0.1.0-27.el5ovirt
qspice-mozilla-0.1.0-27.el5ovirt
qspice-0.1.0-27.el5ovirt
qspice-libs-devel-0.1.0-27.el5ovirt
[root@dhcp-66-70-9 pkgconfig]#

--- Additional comment from ehabkost@redhat.com on 2009-04-28 09:30:30 EDT ---

(In reply to comment #6)
> Another problem, does it also require the 'libXext-devel' package?
> 
> # pkg-config --libs spice
> Package xext was not found in the pkg-config search path.
> Perhaps you should add the directory containing `xext.pc'
> to the PKG_CONFIG_PATH environment variable
> Package 'xext', required by 'Xrandr', not found
> 
> # rpm -qa |grep spice
> qspice-libs-0.1.0-27.el5ovirt
> qspice-mozilla-0.1.0-27.el5ovirt
> qspice-0.1.0-27.el5ovirt
> qspice-libs-devel-0.1.0-27.el5ovirt
> [root@dhcp-66-70-9 pkgconfig]#  

I think that on this case, libXrandr-devel should require libXext-devel. spice.pc doesn't require xext directly.

--- Additional comment from ehabkost@redhat.com on 2009-04-28 11:57:19 EDT ---

(In reply to comment #7)
> 
> I think that on this case, libXrandr-devel should require libXext-devel.
> spice.pc doesn't require xext directly.  

Reported as bug #498044.

--- Additional comment from pmyers@redhat.com on 2009-05-28 22:25:52 EDT ---

This bug is marked as urgent and hasn't seen any activity in about month.  The bug that it is linked to in RHEL5.4 was declined and won't be in that release.  Alan Z, can you make sure that you work w/ RHEL PM to appropriately prioritize bug #498044?

--- Additional comment from ehabkost@redhat.com on 2009-05-29 11:15:45 EDT ---

It is not a serious bug, it is just a missing Requires line for libXext-devel. We just need to work around it on the qspice spec file, by adding a BuildRequires: libXext-devel on it.

This bug is a bit confusing because it _was_ a serious bug and it was marked as blocker, the first time we had an issue. The serious issue was fixed and this bug was reopened due to a minor libXext-devel issue.
Comment 1 Eduardo Habkost 2009-05-29 11:28:44 EDT
Oops, I mean: the real bug is bug #498044.
Comment 2 Yuval Kashtan 2009-06-18 05:52:07 EDT
it seems like a problem in libXrandr-devel, not pulling libXext-devel
and not a problem in qspice-libs-devel...
Comment 3 Yuval Kashtan 2009-06-18 06:02:23 EDT
sorry, my mistake, didn't see it's BuildRequires ...
We need to fix this.
Comment 4 Yuval Kashtan 2009-06-18 07:16:08 EDT
On a second thought - it is a Xrandr bug!
libXrandr-devel should require libXext-devel, as we can see, sometimes it is required.
Comment 5 Eduardo Habkost 2009-06-18 10:17:02 EDT
(In reply to comment #4)
> On a second thought - it is a Xrandr bug!
> libXrandr-devel should require libXext-devel, as we can see, sometimes it is
> required.  

Yes, it is. As I said on comment #0 and comment #1, there is a libXrandr bug reported already (bug #498044), and this is just a request to work around it to avoid trouble.
Comment 6 Yuval Kashtan 2009-06-18 10:20:18 EDT
Why not just solve the bug?
Comment 7 Eduardo Habkost 2009-06-18 10:29:49 EDT
(In reply to comment #6)
> Why not just solve the bug?  

This was the response on bug #498044:

> This request was evaluated by Red Hat Product Management for
> inclusion, but this component is not scheduled to be updated in
> the current Red Hat Enterprise Linux release. If you would like
> this request to be reviewed for the next minor release, ask your
> support representative to set the next rhel-x.y flag to "?".
Comment 10 Yaniv Kamay 2009-06-18 14:32:11 EDT
We also need to add
BuildRequires:  libXrender-devel
Comment 14 Leonid Natapov 2009-07-21 05:46:46 EDT
fixed.
Comment 16 errata-xmlrpc 2009-09-02 06:57:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1334.html

Note You need to log in before you can comment on or make changes to this bug.