Bug 503294 - scitools is unable to useeasyvis
scitools is unable to useeasyvis
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: scitools (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Joseph Smidt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-30 18:18 EDT by Knut J BJuland
Modified: 2009-06-29 23:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 23:49:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
python test program (5.48 KB, text/x-python)
2009-05-30 18:18 EDT, Knut J BJuland
no flags Details
ODESolver (2.50 KB, text/x-python)
2009-05-31 07:06 EDT, Knut J BJuland
no flags Details
oscillator.py plot (524.11 KB, image/png)
2009-05-31 12:18 EDT, Joseph Smidt
no flags Details

  None (edit)
Description Knut J BJuland 2009-05-30 18:18:56 EDT
Created attachment 345991 [details]
python test program

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. python oscillator.py

2.
3.
  
Actual results:
Traceback (most recent call last):
  File "oscillator.py", line 2, in <module>
    from scitools.all  import *
  File "/usr/lib/python2.6/site-packages/scitools/all.py", line 16, in <module>
    from scitools.easyviz import *
  File "/usr/lib/python2.6/site-packages/scitools/easyviz/__init__.py", line 1515, in <module>
    exec(cmd)
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.6/site-packages/scitools/easyviz/gnuplot_.py", line 531
    title=item.getp('legend'), with=withstring,


Expected results:

SHould run porgram which is attachted
Additional info:
Comment 1 Joseph Smidt 2009-05-31 03:07:20 EDT
Thank you for your bug report.  When I run your attached script I get this error:

scitools.easyviz backend is gnuplot
Traceback (most recent call last):
  File "oscillator.py", line 3, in <module>
    from ODESolver import *
ImportError: No module named ODESolver


Apparently you need a module ODESolver to run this script.  Do you have this installed?  If so, could you tell me where to find it so I can do further testing?  Thanks.
Comment 2 Knut J BJuland 2009-05-31 07:06:26 EDT
Created attachment 346005 [details]
ODESolver 

THIS is the ODESOlver which the test program need. It solve differntial equation.
Comment 3 Knut J BJuland 2009-05-31 07:07:59 EDT
Just put the ODESolver in the same folder as the test program. ODESolver were writen by the same authors as scitools.
Comment 4 Joseph Smidt 2009-05-31 12:18:45 EDT
Created attachment 346014 [details]
oscillator.py plot
Comment 5 Joseph Smidt 2009-05-31 12:28:05 EDT
Okay, if you see the attached plot you will see scitools is working just fine for me on Fedora 10.  

Now it looks like you are running rawhide which uses python 2.6.  It looks like there are two upstream bugs related to python 2.6 where easyviz doesn't work:
http://code.google.com/p/scitools/issues/detail?id=5
http://code.google.com/p/scitools/issues/detail?id=6

I did not know about these issues until your report.  Is there any way if you can verify if your problems are related to these?  

Anyways, I will be testing scitools personally with python 2.6 when F-11 is released in a couple weeks.  Hopefully then I can figure out what exactly is going on and how to fix it. Thanks for your report.
Comment 6 Joseph Smidt 2009-05-31 12:30:38 EDT
I would also like to point out the upstream authors claim the new version of scitools to be released soon fixes the python 2.6 bugs.
Comment 7 Bug Zapper 2009-06-09 12:52:00 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Joseph Smidt 2009-06-29 23:49:23 EDT
This bug has been resolved with the recent upgrade to scitools 0.6.  The upstream author provides new examples code, which contains the new version or oscillator.py, to go with this version of the program: http://folk.uio.no/hpl/scripting/TCSE3-3rd-examples.tar.gz

Note You need to log in before you can comment on or make changes to this bug.