This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 503406 - F11: libvirt: cannot shutdown virtual machines booted to a console prompt
F11: libvirt: cannot shutdown virtual machines booted to a console prompt
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-31 15:55 EDT by Gerry Reno
Modified: 2009-06-02 05:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 05:02:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Guest (F10) dmesg (20.72 KB, text/plain)
2009-06-01 09:30 EDT, Gerry Reno
no flags Details
Guest (F10) /proc/interrupts (1.34 KB, text/plain)
2009-06-01 09:31 EDT, Gerry Reno
no flags Details
Guest (F10) acpid process (116 bytes, text/plain)
2009-06-01 09:34 EDT, Gerry Reno
no flags Details

  None (edit)
Description Gerry Reno 2009-05-31 15:55:52 EDT
Description of problem:
Using virtual machine manager, cannot shutdown any virtual machine that is booted to a console prompt (no X).  Virtual machines that are booted to X shutdown fine.


Version-Release number of selected component (if applicable):
libvirt-0.6.2-8.fc11.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:U
Comment 1 Daniel Berrange 2009-06-01 06:07:28 EDT
What guest OS are you running. Is the acpid daemon running ? Please attach contents of /var/log/dmesg, and /proc/interrupts.
Comment 2 Gerry Reno 2009-06-01 09:29:35 EDT
Guest is F10.  Host is F11.  Attaching files from guest.
Comment 3 Gerry Reno 2009-06-01 09:30:53 EDT
Created attachment 346080 [details]
Guest (F10) dmesg
Comment 4 Gerry Reno 2009-06-01 09:31:50 EDT
Created attachment 346081 [details]
Guest (F10)  /proc/interrupts
Comment 5 Gerry Reno 2009-06-01 09:34:29 EDT
Created attachment 346082 [details]
Guest (F10) acpid process
Comment 6 Daniel Berrange 2009-06-01 15:13:56 EDT
That just looks like the kernel ACPI thread, not the userspace daemon. You need the userspace daemon to handle the shutdown requests. Please check the acpid initscript is turned on.
Comment 7 Gerry Reno 2009-06-01 20:37:17 EDT
I checked all the guests and none of them had the acpid package installed.  So we installed acpid on all of them and the shutdown works fine now.

Would it be good if libvirt had a dependency on acpid?
Comment 8 Daniel Veillard 2009-06-02 02:58:53 EDT
c.f. comment #7:
Since libvirt is installed on the host, not on the guest, and the requirement
is to have the guest run acpid, that dependancy would not help, unfortunately.

Daniel

Note You need to log in before you can comment on or make changes to this bug.