Bug 503410 - ERROR with rpm_check_debug vs depsolve - kernel/kmod-nvidia
ERROR with rpm_check_debug vs depsolve - kernel/kmod-nvidia
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-31 16:09 EDT by D. Wagner
Modified: 2014-01-21 18:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-04 02:18:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D. Wagner 2009-05-31 16:09:35 EDT
Description of problem:

Running "yum -y upgrade" gives me the following error.

ERROR with rpm_check_debug vs depsolve:
kernel-uname-r is needed by (installed) kmod-nvidia-2.6.27.9-73.fc9.x86_64-173.14.15-1.fc9.8.x86_64
kernel-uname-r is needed by (installed) kmod-nvidia-2.6.27.12-78.2.8.fc9.x86_64-173.14.15-1.fc9.9.x86_64
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])


Version-Release number of selected component (if applicable):

Currently installed:
yum-3.2.21-2.fc10.noarch
kmod-nvidia-180.51-1.fc10.1.x86_64
kernel-2.6.27.21-170.2.56.fc10.x86_64


How reproducible:

100%

Steps to Reproduce:
1. yum -y upgrade
  
Actual results:

# yum --enablerepo='*' upgrade exaile
Loaded plugins: dellsysidplugin, downloadonly, fastestmirror, fedorakmod,
              : kernel-module, priorities, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rpmfusion-nonfree-updates-testing: mirror.web-ster.com
 * updates-debuginfo: mirror.uoregon.edu
 * rawhide-source: mirror.uoregon.edu
 * rpmfusion-free-updates-testing: mirror.web-ster.com
 * updates-testing: mirror.uoregon.edu
 * livna: rpm.livna.org
 * rpmfusion-nonfree-updates-testing-source: mirror.web-ster.com
 * rpmfusion-nonfree-debuginfo: mirror.web-ster.com
 * updates-testing-source: mirror.uoregon.edu
 * rpmfusion-free-rawhide-debuginfo: mirror.web-ster.com
 * livna-debuginfo: rpm.livna.org
 * rpmfusion-nonfree-updates: mirror.web-ster.com
 * rpmfusion-nonfree-updates-source: mirror.web-ster.com
 * rpmfusion-free-rawhide-source: mirror.web-ster.com
 * fedora: mirror.uoregon.edu
 * rpmfusion-free-debuginfo: mirror.web-ster.com
 * rpmfusion-free-updates-testing-debuginfo: mirror.web-ster.com
 * rpmfusion-nonfree-updates-debuginfo: mirror.web-ster.com
 * rpmfusion-free-rawhide: mirror.web-ster.com
 * rpmfusion-free-updates: mirror.web-ster.com
 * rpmfusion-nonfree-rawhide-debuginfo: mirror.web-ster.com
 * rpmfusion-free: mirror.web-ster.com
 * updates-source: mirror.uoregon.edu
 * rawhide-debuginfo: mirror.uoregon.edu
 * rpmfusion-nonfree-source: mirror.web-ster.com
 * fedora-debuginfo: mirror.uoregon.edu
 * rpmfusion-nonfree-rawhide: mirror.web-ster.com
 * rpmfusion-free-updates-source: mirror.web-ster.com
 * updates-testing-debuginfo: mirror.uoregon.edu
 * rpmfusion-free-updates-testing-source: mirror.web-ster.com
 * rawhide: mirror.uoregon.edu
 * livna-source: rpm.livna.org
 * fedora-source: mirror.uoregon.edu
 * rpmfusion-nonfree-updates-testing-debuginfo: mirror.web-ster.com
 * rpmfusion-nonfree-rawhide-source: mirror.web-ster.com
 * rpmfusion-nonfree: mirror.web-ster.com
 * rpmfusion-free-source: mirror.web-ster.com
 * rpmfusion-free-updates-debuginfo: mirror.web-ster.com
 * updates: mirror.uoregon.edu
rpmfusion-nonfree-updates-testing                        | 2.8 kB     00:00     
rpmfusion-nonfree-updates-testing/primary_db             |  21 kB     00:00     
updates-debuginfo                                        | 2.2 kB     00:00     
updates-debuginfo/primary_db                             | 445 kB     00:03     
rawhide-source                                           | 2.7 kB     00:00     
rawhide-source/primary_db                                | 2.4 MB     00:25     
rpmfusion-free-updates-testing                           | 2.8 kB     00:00     
rpmfusion-free-updates-testing/primary_db                |  39 kB     00:00     
updates-testing                                          | 3.0 kB     00:00     
updates-testing/primary_db                               | 537 kB     00:05     
livna                                                    | 2.4 kB     00:00     
livna/primary_db                                         | 2.7 kB     00:00     
rpmfusion-nonfree-updates-testing-source                 | 2.2 kB     00:00     
rpmfusion-nonfree-updates-testing-source/primary_db      | 8.3 kB     00:00     
rpmfusion-nonfree-debuginfo                              | 2.1 kB     00:00     
updates-testing-source                                   | 2.5 kB     00:00     
updates-testing-source/primary_db                        |  90 kB     00:01     
rpmfusion-free-rawhide-debuginfo                         | 2.7 kB     00:00     
rpmfusion-free-rawhide-debuginfo/primary_db              |  59 kB     00:00     
livna-debuginfo                                          | 1.0 kB     00:00     
livna-debuginfo/primary                                  |  758 B     00:00     
livna-debuginfo                                                             1/1
rpmfusion-nonfree-updates-source                         | 2.2 kB     00:00     
rpmfusion-nonfree-updates-source/primary_db              |  29 kB     00:00     
rpmfusion-free-rawhide-source                            | 2.7 kB     00:00     
rpmfusion-free-rawhide-source/primary_db                 |  86 kB     00:00     
rpmfusion-free-debuginfo                                 | 2.1 kB     00:00     
rpmfusion-free-updates-testing-debuginfo                 | 2.2 kB     00:00     
rpmfusion-free-updates-testing-debuginfo/primary_db      |  11 kB     00:00     
rpmfusion-nonfree-updates-debuginfo                      | 2.2 kB     00:00     
rpmfusion-nonfree-updates-debuginfo/primary_db           |  21 kB     00:00     
rpmfusion-free-rawhide                                   | 3.3 kB     00:00     
rpmfusion-free-rawhide/primary_db                        | 349 kB     00:02     
rpmfusion-nonfree-rawhide-debuginfo                      | 2.7 kB     00:00     
rpmfusion-nonfree-rawhide-debuginfo/primary_db           |  20 kB     00:00     
updates-source                                           | 2.5 kB     00:00     
updates-source/primary_db                                | 930 kB     00:09     
rawhide-debuginfo                                        | 2.7 kB     00:00     
rawhide-debuginfo/primary_db                             | 1.2 MB     00:11     
rpmfusion-nonfree-source                                 | 2.1 kB     00:00     
rpmfusion-nonfree-source/primary_db                      |  21 kB     00:00     
fedora-debuginfo                                         | 2.2 kB     00:00     
rpmfusion-nonfree-rawhide                                | 3.3 kB     00:00     
rpmfusion-nonfree-rawhide/primary_db                     | 103 kB     00:00     
rpmfusion-free-updates-source                            | 2.2 kB     00:00     
rpmfusion-free-updates-source/primary_db                 |  62 kB     00:00     
updates-testing-debuginfo                                | 2.2 kB     00:00     
updates-testing-debuginfo/primary_db                     |  45 kB     00:00     
rpmfusion-free-updates-testing-source                    | 2.2 kB     00:00     
rpmfusion-free-updates-testing-source/primary_db         |  14 kB     00:00     
rawhide                                                  | 3.8 kB     00:00     
rawhide/primary_db                                       |  10 MB     01:38     
livna-source                                             | 1.0 kB     00:00     
livna-source/primary                                     | 1.0 kB     00:00     
livna-source                                                                2/2
fedora-source                                            | 2.2 kB     00:00     
fedora-source/primary_db                                 | 1.9 MB     00:16     
rpmfusion-nonfree-updates-testing-debuginfo              | 2.2 kB     00:00     
rpmfusion-nonfree-updates-testing-debuginfo/primary_db   | 7.0 kB     00:00     
rpmfusion-nonfree-rawhide-source                         | 2.7 kB     00:00     
rpmfusion-nonfree-rawhide-source/primary_db              |  32 kB     00:00     
rpmfusion-free-source                                    | 2.1 kB     00:00     
rpmfusion-free-source/primary_db                         |  55 kB     00:00     
rpmfusion-free-updates-debuginfo                         | 2.2 kB     00:00     
rpmfusion-free-updates-debuginfo/primary_db              |  32 kB     00:00     
16345 packages excluded due to repository priority protections
Setting up Upgrade Process
No Packages marked for Update
[root@mundy]~# yum -y upgrade
Loaded plugins: dellsysidplugin, downloadonly, fastestmirror, fedorakmod,
              : kernel-module, priorities, refresh-packagekit
Loading mirror speeds from cached hostfile
 * rpmfusion-nonfree-updates: mirror.web-ster.com
 * fedora: mirror.uoregon.edu
 * rpmfusion-free-updates: mirror.web-ster.com
 * rpmfusion-free: mirror.web-ster.com
 * rpmfusion-nonfree: mirror.web-ster.com
 * updates: mirror.uoregon.edu
rpmfusion-nonfree-updates                                | 2.8 kB     00:00     
fedora                                                   | 2.8 kB     00:00     
rpmfusion-free-updates                                   | 2.8 kB     00:00     
rpmfusion-free                                           | 2.7 kB     00:00     
adobe-linux-i386                                         |  951 B     00:00     
rpmfusion-nonfree                                        | 2.7 kB     00:00     
updates                                                  | 3.0 kB     00:00     
4 packages excluded due to repository priority protections
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package acpid.x86_64 0:1.0.6-11.fc10 set to be updated
---> Package cronie.x86_64 0:1.2-8.fc10 set to be updated
---> Package dhclient.x86_64 12:4.0.0-35.fc10 set to be updated
---> Package gettext.x86_64 0:0.17-10.fc10 set to be updated
---> Package jetty.x86_64 0:5.1.15-3.fc10 set to be updated
---> Package kernel.x86_64 0:2.6.27.24-170.2.68.fc10 set to be installed
---> Package kernel-devel.x86_64 0:2.6.27.24-170.2.68.fc10 set to be installed
---> Package kernel-firmware.noarch 0:2.6.27.24-170.2.68.fc10 set to be updated
---> Package kernel-headers.x86_64 0:2.6.27.24-170.2.68.fc10 set to be updated
---> Package kmod-nvidia.x86_64 0:180.51-1.fc10.5 set to be updated
--> Processing Dependency: kmod-nvidia-2.6.27.24-170.2.68.fc10.x86_64 >= 180.51-1.fc10.5 for package: kmod-nvidia
---> Package libdhcp4client.x86_64 12:4.0.0-35.fc10 set to be updated
---> Package libnfnetlink.x86_64 0:0.0.41-1.fc10 set to be updated
---> Package libwmf.x86_64 0:0.2.8.4-18.1.fc10 set to be updated
---> Package libwmf-lite.x86_64 0:0.2.8.4-18.1.fc10 set to be updated
---> Package livna-config-display.noarch 0:0.0.23-1.fc10 set to be updated
---> Package ntp.x86_64 0:4.2.4p7-1.fc10 set to be updated
---> Package ntp-perl.x86_64 0:4.2.4p7-1.fc10 set to be updated
---> Package ntpdate.x86_64 0:4.2.4p7-1.fc10 set to be updated
---> Package preupgrade.noarch 0:1.1.0-1.fc10 set to be updated
---> Package wireshark.x86_64 0:1.0.8-1.fc10 set to be updated
---> Package wireshark-gnome.x86_64 0:1.0.8-1.fc10 set to be updated
--> Running transaction check
---> Package kmod-nvidia-2.6.27.24-170.2.68.fc10.x86_64.x86_64 0:180.51-1.fc10.5 set to be updated
--> Finished Dependency Resolution
Excluding to be erased: kernel-2.6.27.5-117.fc10.x86_64
--> Running transaction check
---> Package kernel.x86_64 0:2.6.27.5-117.fc10 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package         Arch   Version                 Repository                 Size
================================================================================
Installing:
 kernel          x86_64 2.6.27.24-170.2.68.fc10 updates                    20 M
 kernel-devel    x86_64 2.6.27.24-170.2.68.fc10 updates                   5.5 M
Updating:
 acpid           x86_64 1.0.6-11.fc10           updates                    35 k
 cronie          x86_64 1.2-8.fc10              updates                    77 k
 dhclient        x86_64 12:4.0.0-35.fc10        updates                   310 k
 gettext         x86_64 0.17-10.fc10            updates                   2.3 M
 jetty           x86_64 5.1.15-3.fc10           updates                   1.9 M
 kernel-firmware noarch 2.6.27.24-170.2.68.fc10 updates                   370 k
 kernel-headers  x86_64 2.6.27.24-170.2.68.fc10 updates                   766 k
 kmod-nvidia     x86_64 180.51-1.fc10.5         rpmfusion-nonfree-updates  24 k
 libdhcp4client  x86_64 12:4.0.0-35.fc10        updates                   282 k
 libnfnetlink    x86_64 0.0.41-1.fc10           updates                    24 k
 libwmf          x86_64 0.2.8.4-18.1.fc10       updates                   142 k
 libwmf-lite     x86_64 0.2.8.4-18.1.fc10       updates                    54 k
 livna-config-display
                 noarch 0.0.23-1.fc10           rpmfusion-nonfree-updates  65 k
 ntp             x86_64 4.2.4p7-1.fc10          updates                   1.4 M
 ntp-perl        x86_64 4.2.4p7-1.fc10          updates                    22 k
 ntpdate         x86_64 4.2.4p7-1.fc10          updates                    57 k
 preupgrade      noarch 1.1.0-1.fc10            updates                    94 k
 wireshark       x86_64 1.0.8-1.fc10            updates                    11 M
 wireshark-gnome x86_64 1.0.8-1.fc10            updates                   632 k
Removing:
 kernel          x86_64 2.6.27.5-117.fc10       installed                  72 M
Installing for dependencies:
 kmod-nvidia-2.6.27.24-170.2.68.fc10.x86_64
                 x86_64 180.51-1.fc10.5         rpmfusion-nonfree-updates 2.6 M

Transaction Summary
================================================================================
Install      3 Package(s)         
Update      19 Package(s)         
Remove       1 Package(s)         

Total size: 47 M
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
kernel-uname-r is needed by (installed) kmod-nvidia-2.6.27.9-73.fc9.x86_64-173.14.15-1.fc9.8.x86_64
kernel-uname-r is needed by (installed) kmod-nvidia-2.6.27.12-78.2.8.fc9.x86_64-173.14.15-1.fc9.9.x86_64
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])


Expected results:

Success

Additional info:

"yum -y --skip-broken upgrade" gives the same error.

"yum -y upgrade kernel kmod-nvidia" gives the same error.

"yum -y --exclude='kernel*' --exclude='kmod-nvidia*' upgrade" succeeds (installs everything except the kernel* and kmod-nvidia* packages), but then "yum -y upgrade" fails with the same error as before (without installing the kernel* or kmod-nvidia* packages).

I wasn't sure whether this is a bug in yum, or rpm, or in the packaging of the kernel or kmod-nvidia packages, so I arbitrarily picked one.  Please re-assign if I have assigned it to the wrong component.

See also http://yum.baseurl.org/ticket/129
Comment 1 seth vidal 2009-06-01 12:17:40 EDT
please update to yum 3.2.23-3 from f10 updates-testing and report back what difference it makes in the error report.

thanks
Comment 2 phil 2009-08-10 08:32:44 EDT
I have the exact same error here on a fedora-11 x86. Here is the listing:

endor ~ $ yum -y upgrade
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Upgrade Process                          
Resolving Dependencies                              
--> Running transaction check
---> Package kernel.i586 0:2.6.29.6-217.2.3.fc11 set to be installed
---> Package kernel-firmware.noarch 0:2.6.29.6-217.2.3.fc11 set to be updated
---> Package kernel-headers.i586 0:2.6.29.6-217.2.3.fc11 set to be updated
---> Package kipi-plugins.i586 0:0.5.0-1.fc11 set to be updated
---> Package kmod-nvidia.i586 0:185.18.14-1.fc11.3 set to be updated
--> Processing Dependency: kmod-nvidia-2.6.29.6-217.2.3.fc11.i586 >= 185.18.14-1.fc11.3 for package: kmod-nvidia-185.18.14-1.fc11.3.i586
--> Running transaction check
---> Package kmod-nvidia-2.6.29.6-217.2.3.fc11.i586.i586 0:185.18.14-1.fc11.3 set to be updated
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.i586 0:2.6.29.4-167.fc11 set to be erased
--> Processing Dependency: kernel-uname-r = 2.6.29.4-167.fc11.i586 for package: kmod-nvidia-2.6.29.4-167.fc11.i586-185.18.14-1.fc11.i586
--> Running transaction check
---> Package kmod-nvidia-2.6.29.4-167.fc11.i586.i586 0:185.18.14-1.fc11 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================================================================================
 Package                                          Arch             Version                           Repository                           Size
===============================================================================================================================================
Installing:
 kernel                                           i586             2.6.29.6-217.2.3.fc11             updates                              21 M
Updating:
 kernel-firmware                                  noarch           2.6.29.6-217.2.3.fc11             updates                             502 k
 kernel-headers                                   i586             2.6.29.6-217.2.3.fc11             updates                             854 k
 kipi-plugins                                     i586             0.5.0-1.fc11                      updates                             4.9 M
 kmod-nvidia                                      i586             185.18.14-1.fc11.3                rpmfusion-nonfree-updates            28 k
Removing:
 kernel                                           i586             2.6.29.4-167.fc11                 installed                            47 M
Installing for dependencies:
 kmod-nvidia-2.6.29.6-217.2.3.fc11.i586           i586             185.18.14-1.fc11.3                rpmfusion-nonfree-updates           2.9 M
Removing for dependencies:
 kmod-nvidia-2.6.29.4-167.fc11.i586               i586             185.18.14-1.fc11                  installed                           9.7 M

Transaction Summary
===============================================================================================================================================
Install      2 Package(s)
Update       4 Package(s)
Remove       2 Package(s)

Total size: 30 M
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
kernel-uname-r = 2.6.27.21-170.2.56.fc10.i686 is needed by (installed) kmod-nvidia-2.6.27.21-170.2.56.fc10.i686-180.51-1.fc10.1.i686
kernel-uname-r = 2.6.27.24-170.2.68.fc10.i686 is needed by (installed) kmod-nvidia-2.6.27.24-170.2.68.fc10.i686-180.51-1.fc10.5.i686
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])

============================================================================

endor ~ $ yum --version
3.2.23
  Installed: rpm-4.7.1-1.fc11.i586 at 2009-08-10 12:14
  Built    : Fedora Project at 2009-07-24 05:07
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2009-07-23 12:00

  Installed: yum-3.2.23-3.fc11.noarch at 2009-06-19 15:18
  Built    : Fedora Project at 2009-05-20 22:29
  Committed: Seth Vidal <skvidal at fedoraproject.org> at 2009-05-20 12:00

  Installed: yum-metadata-parser-1.1.2-12.fc11.i586 at 2009-06-19 15:13
  Built    : Fedora Project at 2009-02-25 18:45
  Committed: Fedora Release Engineering <rel-eng@lists.fedoraproject.org> at 2009-02-25 22:00

All other packets weren't any problem to update, except the kernel package with the nvidia module. 

thanks in advance

Note You need to log in before you can comment on or make changes to this bug.