Bug 503444 - anaconda error when trying to re-install over former LUKS devices
anaconda error when trying to re-install over former LUKS devices
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:f4a841d0dddd72c86...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-01 00:43 EDT by Bill McGonigle
Modified: 2009-09-03 14:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 14:12:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (216.89 KB, text/plain)
2009-06-01 00:43 EDT, Bill McGonigle
no flags Details
Attached traceback automatically from anaconda. (370.18 KB, text/plain)
2009-07-26 10:18 EDT, David Tonhofer
no flags Details

  None (edit)
Description Bill McGonigle 2009-06-01 00:43:04 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.57-1.fc11 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/luks.py", line 133, in teardown
    raise LUKSError("format has not been created")
  File "/usr/lib/anaconda/storage/formats/luks.py", line 162, in destroy
    self.teardown()
  File "/usr/lib/anaconda/storage/deviceaction.py", line 323, in execute
    self.origFormat.destroy()
  File "/usr/lib/anaconda/storage/devicetree.py", line 671, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 238, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 117, in turnOnFilesystems
    anaconda.id.storage.doIt()
LUKSError: format has not been created
Comment 1 Bill McGonigle 2009-06-01 00:43:10 EDT
Created attachment 346047 [details]
Attached traceback automatically from anaconda.
Comment 2 Bill McGonigle 2009-06-01 12:59:07 EDT
I _think_ on this one I refused the installer's request for a password to mount the previous LUKS (on RAID-1) volumes, as I didn't want the content on them and was trying to do a non-LUKS install as the LUKS re-install wasn't working.  If that makes no sense, I could be thinking of the wrong attempt; sorry I didn't keep better notes.

This was the RC2 LiveCD.
Comment 3 James Laska 2009-06-02 18:50:50 EDT
I wonder if this is another way of recreating https://fedoraproject.org/wiki/Common_F11_bugs#502310?
Comment 4 Bill McGonigle 2009-06-02 19:43:28 EDT
It sure sounds similar enough that a fix for one might fix the other.
Comment 5 Bug Zapper 2009-06-09 12:54:48 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 David Tonhofer 2009-07-26 10:18:57 EDT
Created attachment 355195 [details]
Attached traceback automatically from anaconda.
Comment 7 David Tonhofer 2009-07-26 10:24:20 EDT
Comment #6 was automatically created from anaconda.

More info:

The reason for the problem is most probably that the disk on which Fedora 11 shall be installed has already a LUKS partition which I didn't open (from an earlier Fedora 11 installation). Indeed I instructed anaconda through "custom disk setup" to scratch it and rebuild a new LUKS partition on top of it.

Will now zero the partition and try again.
Comment 8 David Lehman 2009-09-03 14:12:31 EDT
This should be fixed in anaconda-12.18-1. We had some issues that popped up when users chose not to provide a passphrase for preexisting LUKS devices.

Note You need to log in before you can comment on or make changes to this bug.