Bug 503527 - OpenGL doesn't seem to run properly
OpenGL doesn't seem to run properly
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-01 11:13 EDT by Alfred Dupont
Modified: 2010-05-20 03:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 06:03:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
result of command "glxinfo" (13.94 KB, text/plain)
2009-06-01 11:15 EDT, Alfred Dupont
no flags Details

  None (edit)
Description Alfred Dupont 2009-06-01 11:13:54 EDT
Description of problem:
OpenGL apps don't start (e.g. glxgears)

Version-Release number of selected component (if applicable):


How reproducible : Steps to Reproduce :
1 - install nvidia drivers (x86_64)
2 - run glxgears
  
Actual results:
Error: glXCreateContext failed

Expected results:
glxgears has to display an animation

Additional info:

backtrace & result of "glxinfo" in attachment

backtrace :

$ gdb glxgears
GNU gdb (GDB) Fedora (6.8.50.20090302-23.fc11)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...

warning: Unable to open "librpm.so" (librpm.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type), missing debuginfos notifications will not be displayed
Missing separate debuginfo for /usr/bin/glxgears
Try: yum --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/43/3336b011ed5cde66307c425b140f4f0b1c173d.debug
(gdb) run
Starting program: /usr/bin/glxgears 
Missing separate debuginfo for /lib64/ld-linux-x86-64.so.2
Try: yum --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/cb/5481c697c4d91fceaf291c97616f3c61e37345.debug
Missing separate debuginfo for /lib64/libm.so.6
Try: yum --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/48/3f88cc6fa4c4805f475487eeb65215d22b4078.debug
Missing separate debuginfo for /lib64/libc.so.6
Try: yum --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/f4/3ed7b0ca9a9882a783f30596de30318a8a6d43.debug
Missing separate debuginfo for /usr/lib64/libX11.so.6
Try: yum --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/26/c4df678f18b51fa99bdeb69d81d3196eab7fd6.debug
Missing separate debuginfo for /usr/lib64/libXext.so.6
Try: yum --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/e6/8e068b91bcd4d55b1326012940d6fa221c6be8.debug
Missing separate debuginfo for /lib64/libdl.so.2
Try: yum --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/7f/87ff4f621a600cd5e94f3294463df124118d8d.debug
Missing separate debuginfo for /usr/lib64/libxcb.so.1
Try: yum --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/42/b99a4f3757507ddad460f05af406f27570431d.debug
Missing separate debuginfo for /usr/lib64/libXau.so.6
Try: yum --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/3b/ac64bd2ed20c326776dcc40430af707a57ae4c.debug
Error: glXCreateContext failed

Program exited with code 01.
Comment 1 Alfred Dupont 2009-06-01 11:15:31 EDT
Created attachment 346090 [details]
result of command "glxinfo"
Comment 2 Nils Philippsen 2009-06-02 06:03:41 EDT
The open source 'nouveau' driver (in package xorg-x11-drv-nouveau) is the recommended alternative for users of Nvidia graphic chips.  It is used by default in Fedora 11 and later if you remove any customizations that explicitly set the video driver.  The older "nv" driver may be needed in some cases.  It is also available in older Fedora releases.  Install the packages xorg-x11-drv-nouveau or xorg-x11-drv-nv and override the X server's default choice if necessary.  See https://fedoraproject.org/wiki/Features/NouveauAsDefault for more information.

If you used a non-packaged version of the driver from the Nvidia website please clean your system from additional libraries and software it installed.  For users who are experiencing problems installing, configuring, or using the unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides indirect customer support via an online web based support forum.  Nvidia monitors these web forums for commonly reported problems and passes them on to Nvidia engineers for investigation.  Once they've isolated a particular problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

	http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have experienced the particular problem may be able to assist.  If there is a real bug occuring, Nvidia will be able to determine this, and will likely resolve the issue in a future driver update for the operating system releases that they officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring technical support may also find the various X.Org, XFree86, and Red Hat mailing lists helpful in finding assistance:

X.Org mailing lists:
	http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
	http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
	https://listman.redhat.com/mailman/listinfo
Comment 3 Nils Philippsen 2009-06-02 06:18:22 EDT
This time with the ommitted leading paragraph:

--- 8< ---
Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

The open source 'nouveau' driver (in package xorg-x11-drv-nouveau) is the
recommended alternative for users of Nvidia graphic chips.  It is used by
default in Fedora 11 and later if you remove any customizations that explicitly
set the video driver.  The older "nv" driver may be needed in some cases.  It
is also available in older Fedora releases.  Install the packages
xorg-x11-drv-nouveau or xorg-x11-drv-nv and override the X server's default
choice if necessary.  See
https://fedoraproject.org/wiki/Features/NouveauAsDefault for more information.

If you used a non-packaged version of the driver from the Nvidia website please
clean your system from additional libraries and software it installed.  For
users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular
problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

 http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve
the issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
 http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
 http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
 https://listman.redhat.com/mailman/listinfo
Comment 4 Alfred Dupont 2009-06-02 13:03:44 EDT
Sorry for this mistake and thank you for NouVeau
Comment 5 russell.cruie 2010-05-20 03:30:24 EDT
wow nice information

Note You need to log in before you can comment on or make changes to this bug.