Bug 503536 - sosreport fails on minimal install without bzip2 installed
sosreport fails on minimal install without bzip2 installed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Stokes
BaseOS QE
:
Depends On:
Blocks: 510760
  Show dependency treegraph
 
Reported: 2009-06-01 12:16 EDT by Olivier Fourdan
Modified: 2013-03-03 21:48 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Sos archives its findings in a tar.bz2 file. However, neither tar nor bzip2 were listed as requirements in the sos package. Therefore, on minimal installations that included neither of these tools, sos would produce an empty tar.bz2 file. Sos now requires both these tools, which enable it to create its report.
Story Points: ---
Clone Of:
: 510760 (view as bug list)
Environment:
Last Closed: 2009-09-02 03:31:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Fourdan 2009-06-01 12:16:25 EDT
Description of problem:

running sosreport on a stripped-down minimal installation without bzip2 produces an empty tar.bz2 file

Version-Release number of selected component (if applicable):

sos-1.7-9.16.el5_3.5

How reproducible:

100% reproducible

Steps to Reproduce:
1. Install a system with minimum package, excluding bzip2
2. run sosreport
  
Actual results:

The tar file in /temp is empty

Expected results:

The tar file is not empty

Additional info:

This is because the result is packed using "tar -jcf ..." (packageResults() in lib/sos/policyredhat.py) but neither tar not bzip2 are listed in the requirements

The spec file should list:

  Requires: libxml2-python
  Requires: tar, bzip2
Comment 5 Chris Ward 2009-07-03 14:44:50 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 8 Ruediger Landmann 2009-09-01 22:59:47 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Sos archives its findings in a tar.bz2 file. However, neither tar nor bzip2 were listed as requirements in the sos package. Therefore, on minimal installations that included neither of these tools, sos would produce an empty tar.bz2 file. Sos now requires both these tools, which enable it to create its report.
Comment 9 errata-xmlrpc 2009-09-02 03:31:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1418.html

Note You need to log in before you can comment on or make changes to this bug.