Bug 503571 - [Cisco 5.4 bug] pktgen very slow
[Cisco 5.4 bug] pktgen very slow
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: rc
: 5.4
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
: OtherQA
Depends On:
Blocks: 475528
  Show dependency treegraph
Reported: 2009-06-01 14:39 EDT by Scott Feldman
Modified: 2009-07-09 20:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-09 20:23:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Scott Feldman 2009-06-01 14:39:59 EDT
Description of problem:

We tried to verify another issue with 2.6.18-149.e15.gtest.71 and we ran into an issue with pktgen.   When we run pktgen with this test kernel, we're getting a very slow pkt rate: something like 30 pps.  If we revert back to the GA kernel, then pktgen runs at ~1Mpps, which is the rate we expect.  We tried both ixgbe and non-ixgbe interfaces and got the same result with the test kernel.

Version-Release number of selected component (if applicable):


How reproducible:

Run pktgen with 1500 byte pkts, no delay and observe pkt rate.

Steps to Reproduce:
Actual results:


Expected results:


Additional info:
Comment 1 Andrius Benokraitis 2009-06-09 11:39:09 EDT
Not sure if this is related to kernel or pktgen... thoughts?
Comment 2 Andrius Benokraitis 2009-06-09 11:39:45 EDT
Scott - have you seen this with the latest -152 kernel?
Comment 3 Andrius Benokraitis 2009-06-10 13:01:32 EDT
Scott - you can grab the -152 kernel here:


Just rpm -ivh it on top of RHEL 5.3 GA...
Comment 4 Andrius Benokraitis 2009-07-09 10:31:09 EDT
Scott - have you tried the latest kernel - we are up to -157 now at the same link above. We are pretty much out of runway on 5.4.
Comment 5 Scott Feldman 2009-07-09 16:48:32 EDT
I tried pktgen with enic on 2.6.18-155.e15 and pktgen works great.  I don't know if this was a mis-test or something was truely wrong with pktgen for a few releases.  In any case, things look good now with the Beta build.  Please close.

Note You need to log in before you can comment on or make changes to this bug.