Bug 503594 - When Solaris patches cannot be backed out, rhn_check reports that the patch was removed successfully
When Solaris patches cannot be backed out, rhn_check reports that the patch w...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Solaris (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Clifford Perry
Red Hat Satellite QA List
: Triaged
Depends On:
Blocks: 462714 479461
  Show dependency treegraph
 
Reported: 2009-06-01 16:00 EDT by Steve Salevan
Modified: 2014-05-09 05:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-09 05:47:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-06-01 16:00:09 EDT
Description of problem:
If a user attempts to back out a Solaris patch using Satellite's patch backout feature, but the backout fails, such as in this instance:

Removing patch-solaris-118777                                 ####################################################################################### [100%]
warning: Got status 256 removing patch-solaris-118777-09-1:                                                                                                 
warning: Validating patches...                                                                                                                              
warning: 
warning: Loading patches installed on the system...
warning: 
warning: Done!
warning: 
warning: Checking patches that you specified for removal.
warning: 
warning: Done!
warning: 
warning: Approved patches will be removed in this order:
warning: 
warning: 118777-09 
warning: 
warning: Checking installed patches...
warning: 
warning: Cannot find the backout packages for 118777-09.
warning: 118777-09 cannot be backed out.
warning: 
warning: Patchrm is terminating.
warning: WARNING: patchrm returned <4>

then rhn_check will send the following response back up to the Satellite:

D: Sending back response (0, "[[['patch-solaris-118777', '09', '1', ''], {}]] removed  successfully", {})

Since the package list is refreshed after this step, the UI still reports the patch as being installed, which is good, but we should probably check the return code from patchrm before reporting this status back to the Satellite.

Version-Release number of selected component (if applicable):
530, 5/29 build

How reproducible:
Always

Steps to Reproduce:
1. Register a Solaris machine to a Satellite
2. Schedule a backout of one of its installed patches where no backout packages exist, such as the patch included in the example
  
Actual results:
As above

Expected results:
Patch remove fails and status reported to Satellite as such

Additional info:

Note You need to log in before you can comment on or make changes to this bug.