Bug 503599 - Cannot have different resolution set if laptop and monitor screen are not same resolution
Cannot have different resolution set if laptop and monitor screen are not sam...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-01 16:30 EDT by Suzanne Yeghiayan
Modified: 2009-08-07 11:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-07 11:53:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Yeghiayan 2009-06-01 16:30:30 EDT
Description of problem:
Running RHEL 5.3 CSB on Lenovo Thinkpad T61.  It's happy at 1440x900 res.
I got a ViewSonic VA2226w and it really wants to be at 1680x1050.  Unfortunately it looks like I'm unable to have different resolutions on cloned screens.

Version-Release number of selected component (if applicable):
RHEL 5.3 CSB

How reproducible:
ViewSonic VA2226w is blurry at 1440x900.

Steps to Reproduce:
1. Set res to 1440x900.
2. Observe T61 res is good.
3. Observe VA2226w is not so good.
  
Actual results:
See 3.

Expected results:
Would like to be able to set T61 res at 1440x900 and VA2226w res at 1680x1050.

Additional info:
Comment 1 Suzanne Yeghiayan 2009-06-01 16:57:01 EDT
Now that I entered the bugzilla, I learned of a work around in our own Desktop QE team.  Here's what I did:

1.  I had to change my laptop to not suspend when lid is closed and still in docking station.
2.  Close laptop lid.
3.  Restart X - ctrl-alt-bspace.
4.  Run xrandr to see the 1680x1050 res.
5.  Run xrandr -s 0 (or whichever number it is) to set it to the 1680x1050 res.

Monitor is all good.

When undock,

1.  Open laptop lid.
2.  Undock laptop.
3.  Hit laptop's func-F7.

Laptop is good.

To redock,

1.  Dock laptop.
2.  Close laptop lid enough to shut off laptop internal monitor but still access keyboard.
3.  Hit laptop's func-F7.
4.  Close laptop lid.

Monitor is all good.

Who knows what will happen when restart X undocked (on laptop).
Comment 2 Suzanne Yeghiayan 2009-06-02 11:52:29 EDT
My new cleaner work around for redocking was to setup this:

1.  Right click on top panel and click on "Add to Panel".
2.  Select "Custom Application Launcher" and then "Add".
3.  In Create Launcher, added this app:
      Name: Fix Resolution 
      Command: xrandr -s 0
    and picked an icon for it.

I will now run this app when I redock and need to fix the resolution of my monitor.
Comment 3 Adam Jackson 2009-06-24 14:39:04 EDT
> Unfortunately it looks like I'm unable to have different resolutions on cloned
> screens.

That's sort of the definition of cloning.  What behaviour are you expecting here?
Comment 4 Suzanne Yeghiayan 2009-08-07 11:53:15 EDT
Sorry for not replying sooner.  I've been fine using func-F7 when docking/undocking which adjusts the resolution accordingly.

Note You need to log in before you can comment on or make changes to this bug.