Bug 503607 - Firefox needs to register the proper name with session management for restart
Firefox needs to register the proper name with session management for restart
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Martin Stransky
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-01 17:29 EDT by ritz
Modified: 2011-01-06 08:01 EST (History)
4 users (show)

See Also:
Fixed In Version: firefox-3.6.13-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-06 08:01:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ritz 2009-06-01 17:29:23 EDT
Description of problem:
Firefox currently registers the full path to the binary executable with Unix
session management.  This causes problems because this skips running the usual
shell wrapper script.  I think Firefox should register "firefox" with session
management and let it be found in the search path.


Version-Release number of selected component (if applicable):
3.x

How reproducible:
always

Steps to Reproduce:
1. run /usr/lib{64}/firefox-<version>/firefox
  
Actual results:
MOZ_PLUGIN_PATH not set

Expected results:
MOZ_PLUGIN_PATH not set

Additional info:
upstream bz
https://bugzilla.mozilla.org/show_bug.cgi?id=453689
Comment 2 Issue Tracker 2009-07-21 16:56:47 EDT
Event posted on 07-21-2009 04:56pm EDT by cwyse

Just gave this a shot with xulrunner-1.9.1-1 and the problem still seems to
occur.


This event sent from IssueTracker by cwyse 
 issue 289674
Comment 4 Charlie Wyse 2009-08-06 14:15:59 EDT
Just patched firefox rpm.  This still does not work.  Can you possibly give us a SRPM or spec file with the patch you know works?
Comment 5 Charlie Wyse 2009-08-06 14:16:25 EDT
The patches I got were from comment #3.
Comment 6 Martin Stransky 2009-08-07 02:50:30 EDT
The fix requires Firefox 3.5.2.
Comment 7 Charlie Wyse 2009-08-07 13:26:51 EDT
Yes, we have 2.5.2.  Are they patches to fix it?  I would like to test this out?
Comment 11 RHEL Product and Program Management 2010-12-07 04:44:37 EST
This request was evaluated by Red Hat Product Management for inclusion in Red Hat Enterprise Linux 5.6 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.
Comment 12 Martin Stransky 2011-01-06 08:01:38 EST
Already fixed in firefox-3.6.13-2.el5.

Note You need to log in before you can comment on or make changes to this bug.