Bug 503649 - No KDE Screensavers/screen savers work
No KDE Screensavers/screen savers work
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-01 23:06 EDT by gene smith
Modified: 2009-07-06 16:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 16:40:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gene smith 2009-06-01 23:06:27 EDT
Description of problem:
Have tried a couple KDE screensavers under "Desktop" setting and none seem to run when they timeout (set to 1 minute) for test. However the small preview appears on the setting page and the test button activates the saver. Also, set upper right corner to "lock the screen" and nothing happen with that either.


Version-Release number of selected component (if applicable):
KDE 4.2.3


How reproducible:
Always, for me never see screen saver.


Steps to Reproduce:
1. Enable screen saver under "system setting" | "desktop"
2. Set time on saver to 1 min and enabled upper right screen corner to activate.
3. I see that the test runs and preview runs. Wait at least a minute.
4. No screensaver ever appears.
5. Put mouse in upper right corner of screen.
6. Screensaver never appears nor does screen "lock".
  
Actual results:
No screen saver every visible in KDE.


Expected results:
Saver should run after 1 min inactive or when mouse in upper right corner as it is configured.


Additional info:
I usually run KDE slide show screen saver. However, I am testing with BSOD saver right now. But I see process kslideshow.kss running in "top". Not sure why that is when kslideshow is not the enabled screensaver!
Comment 1 Steven M. Parrish 2009-06-02 08:26:16 EDT
Thank you for taking the time to report this issue.

This is an issue that needs to be addressed by the upstream developers. Please report this at http://bugs.kde.org and then add the upstream report information to this report.  We will monitor the upstream report for a resolution to this issue.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 gene smith 2009-06-02 23:36:22 EDT
Before I report this upstream I just want to add that I have KDE 4.2.3 on kubuntu 9.04 installed on another drive on the same machine and the KDE screen savers (including slideshow) seem to work properly there. I can also enable it by configuring the upper right screen corner as "lock screen." I only see kscreensaver.kss running when the screen saver is actually active and visible.

So, since the KDE screensaver seems to work OK in kubuntu 9.04 (jaunty) I am curious as to why you think the problem is upstream and not fedora 11 specific? (I have used this same feature in fedora 8 and earlier for many years with no problem.)
Comment 3 Rex Dieter 2009-06-03 00:23:09 EDT
Uncertain, but I can assure you that the screensaver isn't broken universally, it works fine here on my 2 f11 boxes.
Comment 4 Bug Zapper 2009-06-09 12:57:29 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 gene smith 2009-06-29 23:49:18 EDT
Yesterday I was about to report that this was now working. I had uninstalled the kde-art advanced screensavers so I only had the basic ones. They didn't work either. Then after update to KDE 4.3.4 yesterday, I re-installed the advanced KDE savers (along with xscreensaver which it is dependent on) and the xscreensaver daemon started when I tested an xscreensaver. (Before it would always fail to start). Then I noticed that KDE screensavers (e.g.,slideshow) started working for the first time. I disabled the xscreensaver and kde slideshow kept working. It would time out and start and putting the mouse cursor at the upper right screen corner started it. Finally it was working!

Then on startup today KDE savers refused to run again. But the xscreen daemon still seems to run. I have no idea why I have this problem. Maybe it will start working again and stay working, I hope.

(Note: I have reported several KDE "regressions" upstream but never got a response on them, so reporting this would also probably go into a black hole.)
Comment 6 Kevin Kofler 2009-06-30 10:38:56 EDT
> (Note: I have reported several KDE "regressions" upstream but never got a
> response on them, so reporting this would also probably go into a black hole.)

It's the only thing you can do. Here, it's definitely a black hole. ;-(

The big problem is that from your description, your issues appear to be somewhat random / hard to reproduce. Those bugs are always extremely hard for developers to fix.
Comment 7 gene smith 2009-07-06 16:30:28 EDT
Well, I finally got a chance to really look at this. I think my problem was just corrupted files in ~/.kde/share/config. I think they must have been bad because I had saved off all of ~ before upgrading to f11. The configuration files in .kde saved were from 3.5.x (f8 vintage). When I copied back in my old saved off ~ something didn't mesh, although everything seemed to work and could be configured, except KDE screensavers.

So I logged in as another user and moved my current ~/.kde to ~/.kde-orig. Then when I logged back in as myself it created a new default ~/.kde and the screensavers worked. Then, logged in as another kde user, I copied the newer (non-3.5.x based on dates) saved configuration files from .kde-orig/share/config/ back to .kde/share/config/ and I got most of my previous setup back AND screensavers continued to work. I had to do a few minor tweaks to get everything back the way I had it, but everything works now, including kde screensavers.

So I guess the lesson is to pitch out any old kde 3 configuration files before starting to configure kde 4.
Comment 8 Rex Dieter 2009-07-06 16:40:35 EDT
In a perfect world, doing as you did originally *should* work, and if possible, if you could determine what the troublemaker(s) were, then we'd have a good chance to fix it.

That said, I understand that's not likely to happen, so enjoy you're now-working screensaver(s). :)

Note You need to log in before you can comment on or make changes to this bug.