Bug 503693 - Packagekit breaks afte installing rpm-warm-cache
Packagekit breaks afte installing rpm-warm-cache
Status: CLOSED DUPLICATE of bug 501108
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 04:53 EDT by DemetrisK
Modified: 2009-06-03 04:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 04:42:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description DemetrisK 2009-06-02 04:53:53 EDT
Description of problem:
Packagekit (and it's guis) don't work as it should after installing rpm-warm-cache.

Version-Release number of selected component (if applicable):
Latest versions from Rawhide for both component

How reproducible:


Steps to Reproduce:
1.install rpm-warm-cache plugin
2.try to use packagekit (update manager, add/remove programs...)
3.remove rpm-warm-cache plugin and try again
  
Actual results:
An error dialog shows up with the following
Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2461, in _check_init
    self.yumbase.repos.doSetup()
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 79, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 179, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rpm-warm-cache.py", line 32, in postreposetup_hook
    cmd = commands[0]
TypeError: 'NoneType' object is unsubscriptable


Expected results:
Get updates/Get a list of packages

Additional info:
Comment 1 Richard Hughes 2009-06-02 05:19:55 EDT
Can you please try: https://admin.fedoraproject.org/updates/PackageKit-0.4.8-1.fc11
Comment 2 Richard Hughes 2009-06-03 04:42:47 EDT

*** This bug has been marked as a duplicate of bug 501108 ***

Note You need to log in before you can comment on or make changes to this bug.