Bug 503699 - cdda2ogg has runtime dependency on vorbis-tools
cdda2ogg has runtime dependency on vorbis-tools
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cdrkit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 05:46 EDT by Michal Nowak
Modified: 2014-02-02 17:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-05 08:03:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2009-06-02 05:46:57 EDT
Description of problem:

newman@dhcp-lab-124 ~ $ cdda2ogg 
Encoder not found. Install one first! (eg. vorbis-tools)

<< vorbis-tools installed >>

newman@dhcp-lab-124 ~ $ cdda2ogg 
Looking for available tracks...
ERROR: No valid audio tracks detected

--> OK

Version-Release number of selected component (if applicable):

icedax-1.1.9-4.fc11.x86_64
(inherited from cdrkit-1.1.9-4.fc11)

How reproducible:

always

Actual results:

Script /usr/bin/cdda2ogg fails to run, when vorbis-tools are missing.

Expected results:

Require: vorbis-tools in spec file
Comment 1 Roman Rakus 2009-06-02 08:51:10 EDT
Yep. Thanks for the report.
Comment 2 Jörg Schilling 2009-06-03 18:38:42 EDT
The cdrtools fork "cdrkit" is unable to properly 
run on a system with running "hald". This is a result
of design bugs introduced by cdrkit.

Did you try to use the real cdda2wav instead of the 
fork "icedax"?

I recommend you to use the original software from

ftp://ftp.berlios.de/pub/cdrecord/aplha/

Please also note:

The file cdda2ogg is currently unsupported and
the file cdda2ogg that you see is not the original,
so the bug may also be in the script......

You may like to try the file cdda2ogg as distributed with 
the original software.....
Comment 3 Michal Nowak 2009-06-04 04:29:00 EDT
(In reply to comment #2)
> The cdrtools fork "cdrkit" is unable to properly 
> run on a system with running "hald". This is a result
> of design bugs introduced by cdrkit.
> 

That might be possible but I am afraid it has nothing to do with this bug report. Can you provide more details in separate report?

> Did you try to use the real cdda2wav instead of the 
> fork "icedax"?
> 

Nope - it's not in Fedora and the problem here is clear, package cdrkit/icedax is missing vorbis-tools in it's Require field.

> I recommend you to use the original software from
> 
> ftp://ftp.berlios.de/pub/cdrecord/aplha/
> 

Thank you for advice but recent versions of cdrecord are not usable for me from legal POV.

> Please also note:
> 
> The file cdda2ogg is currently unsupported and

Well, I believe it is supported from cdrkit upstream.

> the file cdda2ogg that you see is not the original,
> so the bug may also be in the script......
> 
> You may like to try the file cdda2ogg as distributed with 
> the original software.....  

That's not very likely unless distributors decide to push cdrecord back to repositories. Thanks for you comment, though, Jörg.
Comment 4 Jörg Schilling 2009-06-04 04:39:30 EDT
You seem to be a victim of missinformation from some 
OSS enemies.....

The original software has absolutely no problems with legality.

It is the fork distributed by Redhat that is in conflict with
the Copyright law and for this reason cannot be dstributed
legally. Note that RedHat needs to be aware for being sued 
because Redhat distributes the illegal fork. 

BTW: Debian did already promise to go back to the legal original 
software.

Hint: In order to have the permission to sue people, you need to
own the Copyrights on the related software. The people who 
claim that there is a problem with the original software do not
own the Copyright on the software and therfore cannot sue anybody.
It is obvious that there is a big FUD campaign against the legal OSS
software cdrtools....
Comment 5 Michal Nowak 2009-06-04 04:50:34 EDT
Jörg, please, file separate bug report and block against bug "FE-LEGAL", in case you feel your copyright is in threat from Fedora side. Stop polluting this completely unrelated bug report.

Since no one here is lawyer, we act as we are advised from Fedora legal folks, nothing more, nor less.
Comment 6 Jörg Schilling 2009-06-04 06:53:22 EDT
In case you did not realize this, you polluted this bug tracking
system with incorrect claims in your previous report, so you 
initiated my reply.

I recommend the Fedora folks to ask real lawyers in order to
get correct information. I asked lawyers and so did e.g. Sun
and Sun does distribute the original software because the Sun 
legal department did make an in depth legal review on the license 
situation.

Simon Phipps (the Sun OpenSource evangelist) did convince Debian 
and Debian promised to start distributing the legal original software
soon. When will Redhat do the same?

Keep in mind that I am the Copyright holder and I am not amused
to see redhat distributing a fork that is in conflict wth the
Copyright law. 

BTW: I tried to get into contact with Redhat legal to no avail and 
this is why I see no other way to inform people about the situation.
Comment 7 Michal Nowak 2009-06-04 07:16:39 EDT
Use fedora-legal-list http://www.redhat.com/mailman/listinfo/fedora-legal-list for such concerns not random bugzilla entry, please. I am afraid that's the only think I can do for you in here from my engineer POV.
Comment 8 Bug Zapper 2009-06-09 12:58:13 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Nikola Pajkovsky 2009-07-16 12:05:29 EDT
Spec file was changed. I added Require for vorbis-tools for icedax.

Note You need to log in before you can comment on or make changes to this bug.