Bug 503721 - virt-image don't support --prompt options
virt-image don't support --prompt options
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks: 574270
  Show dependency treegraph
 
Reported: 2009-06-02 07:53 EDT by Alex Jia
Modified: 2010-03-30 04:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 574270 (view as bug list)
Environment:
Last Closed: 2010-03-30 04:51:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-image: Hide unimplemented --prompt option from --help output (3.56 KB, text/plain)
2009-12-13 14:11 EST, Cole Robinson
no flags Details

  None (edit)
Description Alex Jia 2009-06-02 07:53:49 EDT
Description of problem:


Version-Release number of selected component (if applicable):
[root@dhcp-66-70-18 ~]# uname -r
2.6.18-151.el5xen
[root@dhcp-66-70-18 ~]# rpm -qa|grep python-virtinst
python-virtinst-0.400.3-1.el5
[root@dhcp-66-70-18 ~]# rpm -qa|grep libvirt
libvirt-python-0.6.3-3.el5
libvirt-0.6.3-3.el5
libvirt-debuginfo-0.6.3-3.el5
libvirt-0.6.3-3.el5

How reproducible:
virt-image --prompt

Steps to Reproduce:
1.
2.
3.
  
Actual results:
don't support --prompt options

Expected results:
support --prompt options

Additional info:
[root@dhcp-66-70-18 ~]# virt-image --prompt
usage: virt-image [options] image.xml

virt-image: error: You need to provide an image XML descriptor
Comment 1 Cole Robinson 2009-12-10 14:01:52 EST
Providing prompting for virt-image will be a decent amount of work for not a lot of gain since I'm pretty sure this tool has near 0 users. I think the best thing to do will just be to hide the --prompt option (but not error out to maintain back compat).
Comment 2 Cole Robinson 2009-12-10 16:18:21 EST
Fixed upstream, should be an easy backport:

http://hg.fedorahosted.org/hg/python-virtinst/rev/fc962689be97
Comment 3 Cole Robinson 2009-12-13 14:11:05 EST
Created attachment 378060 [details]
virt-image: Hide unimplemented --prompt option from --help output
Comment 4 Cole Robinson 2009-12-13 14:11:38 EST
Fix built in python-virtinst-0.400.3-6.el5
Comment 8 errata-xmlrpc 2010-03-30 04:51:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0282.html

Note You need to log in before you can comment on or make changes to this bug.