Bug 503724 - Xen Fully Virt domain may not start
Xen Fully Virt domain may not start
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt-cim (Show other bugs)
5.4
All Linux
high Severity high
: beta
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
: 503736 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 08:04 EDT by Daniel Veillard
Modified: 2011-01-24 18:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:24:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2009:1270 normal SHIPPED_LIVE libvirt-cim bug fix and enhancement update 2009-09-01 08:31:02 EDT

  None (edit)
Description Daniel Veillard 2009-06-02 08:04:41 EDT
Description of problem:
Problem raised by Kaitlin Rupert <kaitlin@linux.vnet.ibm.com>

libvirt-cim generates an incorrect <boot> tag for fully virtualized Xen
guests:

The tag is generated as <boot>hd</boot>, but it should be generated as <boot
dev='hd'/> instead.

Version-Release number of selected component (if applicable):
libvirt-cim-0.5.5-1.el5

How reproducible:
systematic

Steps to Reproduce:
1. Attempt to define a guest (be sure to specify a disk) using DefineSystem()
   CIM interface
2. Attempt to start that guest
3.

Alternatively, if you have cimtest setup, you can run the following test:


Actual results:
missing boot device error

ComputerSystem - 05_activate_defined_start.py: FAIL
You will see the following error:
>> ERROR     - Got CIM error CIM_ERR_FAILED: Failed to define domain:
>> internal error missing boot device with return code 1
>> ERROR     - ERROR: VS 'DomST1' was not defined
>> InvokeMethod(DefineSystem): CIM_ERR_FAILED: Failed to define domain:
>> internal error missing boot device
Expected results:

Guest start normally

Additional info:

Fix is trivial and has been commited upstream:
http://libvirt.org/hg/libvirt-cim/rev/4ac0b029df21
Comment 3 Daniel Veillard 2009-06-03 03:46:11 EDT
*** Bug 503736 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Veillard 2009-06-03 10:00:15 EDT
libvirt-cim-0.5.5-2.el5 has been built in dist-5E-qu-candidate with the fix

Daniel
Comment 10 errata-xmlrpc 2009-09-02 05:24:23 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1270.html

Note You need to log in before you can comment on or make changes to this bug.