Bug 503743 - Traceback: com.redhat.rhn.manager.kickstart.cobbler.NoCobblerTokenException
Traceback: com.redhat.rhn.manager.kickstart.cobbler.NoCobblerTokenException
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Steve Salevan
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-06-02 09:48 EDT by Miroslav Suchý
Modified: 2009-09-21 11:30 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:26:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2009-06-02 09:48:28 EDT
Description of problem:
Some time after installation Satellite will send tracebacks (every 10 minutes).

Version-Release number of selected component (if applicable):
sat530 - Satellite-5.3.0-RHEL5-re20090529.0-i386

How reproducible:
happend to me, and mzazrivec too.

Steps to Reproduce:
1. install satellite
2. wait 2 days
3. tracebacks will start comming
if you restart satellite it will stop coming.
  
Actual results:
Tons of traceback 2 days after installation

Expected results:
No traceback

Additional info:

com.redhat.rhn.manager.kickstart.cobbler.NoCobblerTokenException: We had an error trying to login.
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerLoginCommand.login(CobblerLoginCommand.java:57)
	at com.redhat.rhn.frontend.integration.IntegrationService.authorize(IntegrationService.java:113)
	at com.redhat.rhn.frontend.integration.IntegrationService.getAuthToken(IntegrationService.java:73)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerCommand.<init>(CobblerCommand.java:72)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerDistroSyncCommand.<init>(CobblerDistroSyncCommand.java:49)
	at com.redhat.rhn.taskomatic.task.CobblerSyncTask.execute(CobblerSyncTask.java:83)
	at com.redhat.rhn.taskomatic.task.SingleThreadedTestableTask.execute(SingleThreadedTestableTask.java:54)
	at org.quartz.core.JobRunShell.run(JobRunShell.java:203)
	at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
Caused by: redstone.xmlrpc.XmlRpcFault: cobbler.cexceptions.CX:'login failed: taskomatic_user'
	at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:443)
	at redstone.xmlrpc.XmlRpcClient.endCall(XmlRpcClient.java:376)
	at redstone.xmlrpc.XmlRpcClient.invoke(XmlRpcClient.java:165)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.invokeMethod(CobblerXMLRPCHelper.java:69)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerLoginCommand.login(CobblerLoginCommand.java:52)
	... 8 more
Comment 1 Clifford Perry 2009-06-03 11:58:41 EDT
Justin - take a look at this... maybe tomcat crashed again?
Comment 2 Justin Sherrill 2009-06-04 17:43:43 EDT
Arg, i can't seem to reproduce this at will.  I've installed a couple of different sats (RHEL 5 32bit & 64bit) and changed the date to Sunday morning at 3:55 then waited.  

Cron.daily gets run, but nothing bad happens.  I've also tried running logrotate by hand on the tomcat5 config.  

I'll install a new one and just let it run until Sunday.
Comment 3 Justin Sherrill 2009-06-08 13:25:15 EDT
So the new install didn't reproduce on Sunday.

Gonna just let this one sit until we see it happen again.
Comment 4 Steve Salevan 2009-06-24 17:32:35 EDT
VERIFIED on 6/19 build, as far as my testing can tell.
Comment 5 Brandon Perkins 2009-07-28 16:18:31 EDT
Release Pending.  Clean on Satellite-5.3.0-RHEL5-re20090724.0-x86_64-embedded-oracle.
Comment 6 Brandon Perkins 2009-09-10 15:26:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.