Bug 503774 - X hang (kxb BOGUS LENGTH / RADEON ADVANCE_RING)
X hang (kxb BOGUS LENGTH / RADEON ADVANCE_RING)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 12:14 EDT by Nigel Jones
Modified: 2018-04-11 08:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 08:26:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log file (798.18 KB, text/plain)
2009-06-02 12:34 EDT, Nigel Jones
no flags Details
x11 config (1.57 KB, text/plain)
2009-06-02 12:35 EDT, Nigel Jones
no flags Details

  None (edit)
Description Nigel Jones 2009-06-02 12:14:44 EDT
Description of problem:
Occasionally X session will hang. Display remains list. No mouse pointer visible. caps lock etc inoperative,  on-screen clock frozen. disk/network activity leds on system unit flashing. Able to ssh in remotely. System running at very low cpu.
- no errors from dmesg
- some errors in Xorg.0.log

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.29.4-167.fc11.i686
xorg-x11-drv-ati-6.12.2-15.fc11.i586

Errors noted from Xorg.0.log

(EE) RADEON(0): ADVANCE_RING count != expected (14 vs 16) at radeon_textured_videofuncs.c:1623
FreeType: couldn't open face /usr/share/fonts/cjkuni/ukai.ttc: 1
[xkb] BOGUS LENGTH in write keyboard desc, expected 5788, got 5804

However since no timestamps cannot be sure whether it's related, however last modified timestamp on logfile approx ties with time of "hang"

How reproducible:
Not very. About weekly


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nigel Jones 2009-06-02 12:34:50 EDT
Created attachment 346283 [details]
xorg log file
Comment 2 Nigel Jones 2009-06-02 12:35:50 EDT
Created attachment 346284 [details]
x11 config
Comment 3 Matěj Cepl 2009-06-02 19:08:53 EDT
This error message

(EE) RADEON(0): ADVANCE_RING count != expected (14 vs 16) at radeon_textured_videofuncs.c:1623

is like zillion times in the end of the log. Was not able to find this string on bugs.freedesktop.org
Comment 4 Bug Zapper 2009-06-09 12:59:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Matěj Cepl 2009-06-26 08:32:07 EDT
Take a look at https://fedoraproject.org/wiki/Common_F11_bugs#Miscellaneous_problems_with_ATI_.2F_AMD_graphics_adapters Does any advice there helps you?
Comment 7 Nigel Jones 2009-09-10 02:09:35 EDT
Have not seen this recently -- now on F12/rawhide, so suggest closure.

Note You need to log in before you can comment on or make changes to this bug.