Bug 503778 - memory leak in function graph tracer
memory leak in function graph tracer
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
1.2
All Linux
high Severity high
: 1.3
: ---
Assigned To: Steven Rostedt
David Sommerseth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 12:26 EDT by Steven Rostedt
Modified: 2016-05-22 19:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-12 13:43:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Rostedt 2009-06-02 12:26:59 EDT
Description of problem:

Every time you enable the function graph tracer, it assigns a new ret_stack to the idle tasks. But this does not test to see if it was already allocated. Thus, every time the function graph tracer is enabled we allocate a new ret_stack for idle tasks.

This is a memory leak, and also can cause a crash because it is possible that we replace the ret_stack of the idle task while it is using it.
Comment 1 Clark Williams 2009-10-06 17:04:30 EDT
Is this still a bug?
Comment 2 Steven Rostedt 2009-10-06 22:06:17 EDT
Not for 2.6.31 kernels, but I don't know about anything earlier.
Comment 3 Clark Williams 2009-10-07 10:07:53 EDT
Please take a look at the 2.6.24.7 kernel tree (grab luis' latest git tree) and see if it looks like we have a problem in ftrace there.
Comment 4 Clark Williams 2009-10-07 10:41:58 EDT
Not relevant to v1 kernel (no function graph tracer there); fixed in .31 kernels with git commit: 179c498ae2998461fe436437a74dc29036fc7dcc
Comment 5 Clark Williams 2010-04-12 13:43:47 EDT
included in 2.6.33 kernel

Note You need to log in before you can comment on or make changes to this bug.