Bug 503801 - 500 ISE on updating a cloned rhel channel
500 ISE on updating a cloned rhel channel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
530
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Brad Buckingham
Preethi Thomas
:
Depends On:
Blocks: 456998
  Show dependency treegraph
 
Reported: 2009-06-02 14:45 EDT by Preethi Thomas
Modified: 2009-09-10 15:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:49:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update channel (117.62 KB, image/png)
2009-06-02 14:45 EDT, Preethi Thomas
no flags Details
traceback (1.61 KB, text/plain)
2009-06-03 14:05 EDT, Preethi Thomas
no flags Details

  None (edit)
Description Preethi Thomas 2009-06-02 14:45:22 EDT
Created attachment 346297 [details]
update channel

Description of problem:
clicking on update channel after cloning a rhel channel ends up in 500 ISE

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090529.0-i386-embedded-oracle.iso
How reproducible:


Steps to Reproduce:
1.clone a rhel base channel with all errata
2.once you are  cloned channel page
3.change the channel acl to public
4. click on update channel
  
Actual results:

500 ISE
Expected results:


Additional info:
screen shot attached
Comment 1 Preethi Thomas 2009-06-03 14:05:32 EDT
Created attachment 346439 [details]
traceback
Comment 2 Brad Buckingham 2009-06-08 14:18:11 EDT
The following was observed in the httpd/error_log shortly before the traceback occured:

[Tue Jun 02 13:45:03 2009] [error] (70007)The timeout specified has expired: ajp_ilink_receive() can't receive header
Comment 3 Brad Buckingham 2009-06-09 11:38:03 EDT
master git commit: ba23f87cad5763107528b27ba693ec743e3365aa
vader git commit: e3400ac47bc83676861b79867a1885f11ed208c9

I was able to reproduce the error reliably on an fjs box using the scenario in the description, if step 1 is a rhel 4 base channel.  (With rhel 5, I was not able to reproduce.)

After investigation, the issue appears to be that when processing the EditChannelAction to update the channel details, the logic would also perform a refresh of the 'new package' cache.  This refresh of the cache would take > 2 minutes causing the timeout observed in the error_log, followed by an ISE.  Since the el5 base channel has a lot fewer packages than the el4 base channel, the issue was not easily reproducible with el5.

Since the editing of the channel only involves changing basic details (e.g. name, description, contact info...) associated with the channel and not the packages associated with it, there is no need to refresh the package cache during the edit.  As a result, removed that step from the edit.
Comment 4 Preethi Thomas 2009-06-15 10:18:40 EDT
verified
Satellite-5.3.0-RHEL5-re20090612.0-i386-embedded-oracle.iso
no ISE on cloning Rhel 4 channels
Comment 5 John Sefler 2009-07-31 11:17:58 EDT
Re-verified on build 7/24
I cloned channel with all errata: Clone of Red Hat Enterprise Linux AS (v. 4 for 32-bit x86)
It took 3.5 minutes to clone
I changed the ackl from private to public to protected to private
Did not get an ISE

moving to RELEASE_PENDING
Comment 6 Brandon Perkins 2009-09-10 15:49:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.