Bug 503807 - kqemu is disabled in qemu
kqemu is disabled in qemu
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 15:56 EDT by J Gallagher
Modified: 2009-06-02 17:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 17:15:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J Gallagher 2009-06-02 15:56:37 EDT
Description of problem:
qemu doesn't allow -kernel-kqemu option

Version-Release number of selected component (if applicable):
qemu-0.10.4-4.fc11.i586

How reproducible:


Steps to Reproduce:
1. try qemu -kernel-kqemu ...
2.
3.
  
Actual results:
qemu: invalid option -- '-kernel-kqemu'



Expected results:
kqemu module should be loaded


Additional info:
Comment 1 Glauber Costa 2009-06-02 17:15:42 EDT
This is intended.

Unfortunately, there's no way to build a binary that supports both kvm and kqemu.
There are ongoing upstream threads about it. kqemu is dead technology, not because of its functionalities, but because it imposes *severe* limitation on upstream qemu, and currently no one have the will or skill to maintain it.

In fedora, we don't ship the kernel module, because it is not in upstream kernel. So if you want to run kqemu, you'll need to build the module anyway. Just build your own qemu in that case.

Note You need to log in before you can comment on or make changes to this bug.