This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 503863 - No Crash Recovery window launches after restart crashed evolution [NEEDINFO]
No Crash Recovery window launches after restart crashed evolution
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 00:39 EDT by zhanghaiyan
Modified: 2014-06-03 08:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:48:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (yoyzhang)


Attachments (Terms of Use)

  None (edit)
Description zhanghaiyan 2009-06-03 00:39:34 EDT
Description of problem:
No Crash Recovery window launches after restart crashed evolution

Version-Release number of selected component (if applicable):
Arch: RHEL5.4-Server-x86_64
      RHEL5.4-Client-i386
Version:
      evolution-2.12.3-18.el5
      evolution-data-server-1.12.3-17.el5
      evolution-connector-2.12.3-9.el5

How reproducible:
Always

Steps to Reproduce:
1. Launch evolution
2. Issue command 'evolution --force-shutdown'  in terminal to simulate a crash.
3. Issue command 'evolution '  in terminal.
  
Actual results:
After step3, Evolution opens, but no crash recovery window is launched.

Expected results:
After step3, Evolution opens with Crash Recovery window

Additional info:
Comment 1 liuqian 2009-06-03 03:50:01 EDT
Reproduct on RHEL5.4 Server - i386(en_US), RHEL5.4 Client x86_64 (zh_TW),
RHEL5.4 Server - ia64(ja_JP)
Comment 2 Matthew Barnes 2009-06-03 06:54:06 EDT
(In reply to comment #0)
> 2. Issue command 'evolution --force-shutdown'  in terminal to simulate a crash.

Evolution itself exits cleanly on --force-shutdown.
To simulate a crash do "kill -s SIGSEGV <evolution-pid>".
Comment 3 zhanghaiyan 2009-06-03 23:06:06 EDT
Tested with command "kill -s SIGSEGV <evolution-pid>" to simulate a crash, still no crash recovery window launches after restart evolution.

Also,during test evolution, sometimes evolution crashes itself. Restart crashed evolution, no crash recovery window launches.
Comment 4 RHEL Product and Program Management 2014-03-07 07:41:53 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 5 RHEL Product and Program Management 2014-06-03 08:48:15 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.