Bug 503886 - Host Kernel panic if run systerm_reset when installing F11-preview-x86_64 guest.
Host Kernel panic if run systerm_reset when installing F11-preview-x86_64 guest.
Status: CLOSED DUPLICATE of bug 504018
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
x86_64 Linux
low Severity medium
: beta
: ---
Assigned To: Eduardo Habkost
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 03:47 EDT by lihuang
Modified: 2014-03-25 20:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-04 10:17:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot : QEMU-VNC (19.39 KB, image/png)
2009-06-03 03:47 EDT, lihuang
no flags Details
screen shot : host Fatal exception (662.16 KB, image/png)
2009-06-03 03:49 EDT, lihuang
no flags Details
tar.bz2 : sosreport (2.07 MB, application/x-bzip)
2009-06-03 03:51 EDT, lihuang
no flags Details

  None (edit)
Description lihuang 2009-06-03 03:47:05 EDT
Created attachment 346362 [details]
screen shot : QEMU-VNC

Description of problem:
On my fresh installed RHEL5U4.20090602 host. (kvm is updated to kvm-83-60)
I want to restart the vm installation by system_reset . but the host crashed. 


Version-Release number of selected component (if applicable):
RHEL5.4-Server-20090602.nightly/
[root@dhcp-66-70-80 ~]# rpm -qa | grep kvm
kvm-debuginfo-83-60.el5
kmod-kvm-83-60.el5
kvm-tools-83-60.el5
etherboot-roms-kvm-5.4.4-10.el5
kvm-83-60.el5
etherboot-zroms-kvm-5.4.4-10.el5
kvm-qemu-img-83-60.el5


How reproducible:
3/3

Steps to Reproduce:
1. install the F11-x86_64 guest from cdrom
2. type ' system_reset ' into qemu monitor
3. vm restart. redo the installation
  
Actual results:
Host: Kernel panic - not syncing: Fatal exception

Expected results:


Additional info:
CLI :
qemu-kvm -no-hpet -usbdevice tablet  -rtc-td-hack  -smp 2  -m 2048 -net nic,vlan=0,macaddr=01:21:9B:58:5F:D3,model=rtl8139 -net tap,vlan=0,ifname=test1,script=/etc/qemu-ifup -net nic,vlan=1,macaddr=02:21:9B:58:5F:D3,model=virtio  -net tap,vlan=1,ifname=test2,script=/etc/qemu-ifup -drive file=/kvm/images/70-55-F11-x86_64.qcow2,media=disk,if=ide,cache=off,index=0.boot=on -drive file=/kvm/isos/Fedora-11-Preview-x86_64-DVD.iso,media=cdrom,index=2 -soundhw ac97  -cpu qemu64,+sse2 -uuid `uuidgen` -monitor stdio -vnc :10  -boot  d

host CPU:
processor       : 3
vendor_id       : GenuineIntel
cpu family      : 6
model           : 23
model name      : Intel(R) Core(TM)2 Quad CPU    Q9400  @ 2.66GHz
stepping        : 10
cpu MHz         : 2000.000
cache size      : 3072 KB
physical id     : 0
siblings        : 4
core id         : 3
cpu cores       : 4
apicid          : 3
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx smx est tm2 cx16 xtpr lahf_lm
bogomips        : 5319.98
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

[root@dhcp-66-70-80 ~]#
Comment 1 lihuang 2009-06-03 03:49:42 EDT
Created attachment 346363 [details]
screen shot : host Fatal exception
Comment 2 lihuang 2009-06-03 03:51:23 EDT
Created attachment 346364 [details]
tar.bz2 : sosreport
Comment 3 Yaniv Kaul 2009-06-03 03:53:37 EDT
This looks like a guest kernel panic to me.
Comment 4 lihuang 2009-06-03 04:14:46 EDT
Hi   Yaniv:
you mean the screen shot in comment #0 ? 
yes . that picture is from guest's vnc,

Call Trace of host is in comment #1
Comment 5 Yaniv Kaul 2009-06-03 04:23:58 EDT
(In reply to comment #4)
> Hi   Yaniv:
> you mean the screen shot in comment #0 ? 
> yes . that picture is from guest's vnc,
> 
> Call Trace of host is in comment #1  

So, a guest or a host kernel panic?
Comment 6 Lawrence Lim 2009-06-03 09:15:25 EDT
llim->lihuang, if its guest, try another guest OS. if host, downgrade kernel.
Comment 7 lihuang 2009-06-03 20:40:27 EDT
lihuang -> Yaniv.
it is host kernel panic ( sorry if confused you .) 

lihuang -> llim 
ok . will do it on 5u3.
Comment 8 Lawrence Lim 2009-06-03 22:17:40 EDT
you report a kernel bug without kernel version?
Comment 9 lihuang 2009-06-04 00:42:53 EDT
Update my test result:

On RHEL5U4.20090602
[root@dhcp-66-70-80 ~]# uname -a
Linux dhcp-66-70-80.nay.redhat.com 2.6.18-151.el5 #1 SMP Wed May 27 16:14:57 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

guest\kvm      | kvm-83-41              | kvm-83-60
-------------------------------------------------------
F11 x86_64       only guest panic (1)     host panic (2)
F11 i386         OK                       OK
F10 x86_64       OK                       OK

(1):
the error is same as https://bugzilla.redhat.com/attachment.cgi?id=346362 

(qemu) info block
ide0-hd0: type=hd removable=0 file=/kvm/images/70-55-F11-x86_64.qcow2 ro=0 drv=qcow2
ide1-cd0: type=cdrom removable=1 locked=1 file=/kvm/isos/Fedora-11-Preview-x86_64-DVD.iso ro=0 drv=raw
floppy0: type=floppy removable=1 locked=0 [not inserted]
sd0: type=floppy removable=1 locked=0 [not inserted]

dmesg on host:
[root@dhcp-66-70-80 ~]# dmesg | tail
vcpu not ready for apic_round_robin
vcpu not ready for apic_round_robin
vcpu not ready for apic_round_robin
vcpu not ready for apic_round_robin
vcpu not ready for apic_round_robin
vcpu not ready for apic_round_robin
vcpu not ready for apic_round_robin
vcpu not ready for apic_round_robin
vcpu not ready for apic_round_robin
vcpu not ready for apic_round_robin


(2):the original issue in comment #0
Comment 10 Yaniv Kaul 2009-06-04 02:45:11 EDT
I suggest you split it into two bugs and set up netconsole, to get the full host panic data.
Comment 11 lihuang 2009-06-04 04:22:39 EDT
the full host panic data

Unable to handle kernel NULL pointer dereference at 0000000000000028 RIP:       
 [<ffffffff883b89a4>] :kvm:kvm_get_intr_delivery_bitmask+0x4e/0x86              
PGD 1058b4067 PUD 114e21067 PMD 0                                               
Oops: 0000 [1] SMP                                                              
last sysfs file: /devices/pci0000:00/0000:00:19.0/irq                           
CPU 2                                                                           
Modules linked in: tun nfs fscache nfs_acl ipt_MASQUERADE iptable_nat ip_nat xtd
Pid: 3854, comm: qemu-kvm Tainted: G      2.6.18-151.el5 #1                     
RIP: 0010:[<ffffffff883b89a4>]  [<ffffffff883b89a4>] :kvm:kvm_get_intr_delivery6
RSP: 0018:ffff810112ba1bb8  EFLAGS: 00010246                                    
RAX: 0000000000000000 RBX: ffff810112ba1be8 RCX: ffffffff80306c28               
RDX: ffffffff80306c28 RSI: 0000000000001000 RDI: ffffffff80306c20               
RBP: ffff810112ba1bd8 R08: ffffffff80306c28 R09: 0000000000000001               
R10: 0000000000000002 R11: 0000000000000fe0 R12: ffff810105f2de00               
R13: ffff810105f2de20 R14: 0000000000000001 R15: 0000000000001000               
FS:  0000000041bea940(0063) GS:ffff8101041e5ec0(0000) knlGS:0000000000000000    
CS:  0010 DS: 002b ES: 002b CR0: 000000008005003b                               
CR2: 0000000000000028 CR3: 00000001059cd000 CR4: 00000000000026e0               
Process qemu-kvm (pid: 3854, threadinfo ffff810112ba0000, task ffff81011587f7e0)
Stack:  ffff8101172e5e00 ffff810114174000 ffff810105f2de00 ffffffff883b718f     
 0000000000000003 0000000000000000 0300000000000931 0000000781022fae            
 ffff8101172e5e00 ffff810114174000 00000000ffffffff 0000000000000001            
Call Trace:                                                                     
 [<ffffffff883b718f>] :kvm:ioapic_service+0x55/0x12a                            
 [<ffffffff883b8b8c>] :kvm:kvm_set_irq+0x65/0xa3                                
 [<ffffffff883a9d6e>] :kvm:kvm_arch_vm_ioctl+0x37e/0x62e                        
 [<ffffffff8005aec6>] getnstimeofday+0x10/0x28                                  
 [<ffffffff883a1dc9>] :kvm:mark_page_dirty+0x1c/0x3f                            
 [<ffffffff883a5fd0>] :kvm:kvm_write_guest_time+0x13e/0x147                     
 [<ffffffff80063fc8>] thread_return+0x62/0xfe                                   
 [<ffffffff883a36c4>] :kvm:kvm_vm_ioctl+0xa79/0xad0                             
 [<ffffffff801288ee>] avc_has_perm+0x43/0x55                                    
 [<ffffffff883a88a8>] :kvm:kvm_arch_vcpu_ioctl_run+0x5fd/0x60b                  
 [<ffffffff801291ab>] inode_has_perm+0x56/0x63                                  
 [<ffffffff8008cd53>] default_wake_function+0x0/0xe                             
 [<ffffffff80042691>] do_ioctl+0x21/0x6b                                        
 [<ffffffff80030ae3>] vfs_ioctl+0x457/0x4b9                                     
 [<ffffffff8004cd38>] sys_ioctl+0x59/0x78                                       
 [<ffffffff8005e28d>] tracesys+0xd5/0xe0                                        
                                                                                
                                                                                
Code: 8b 40 28 0f ab 45 00 eb 2a e8 8a 99 cd f7 85 c0 74 19 40 b6               
RIP  [<ffffffff883b89a4>] :kvm:kvm_get_intr_delivery_bitmask+0x4e/0x86          
 RSP <ffff810112ba1bb8>                                                         
CR2: 0000000000000028                                                           
 <0>Kernel panic - not syncing: Fatal exception
Comment 12 Gleb Natapov 2009-06-04 06:03:01 EDT
Is this not a dup for https://bugzilla.redhat.com/show_bug.cgi?id=504018 ?
Comment 13 Eduardo Habkost 2009-06-04 10:13:48 EDT
kvm-83-60.el5 is not a RHEV package, but a RHEL-5 one. This bug is against the wrong product.

It is a duplicate of bug 504018.
Comment 16 Eduardo Habkost 2009-06-04 10:17:47 EDT

*** This bug has been marked as a duplicate of bug 504018 ***

Note You need to log in before you can comment on or make changes to this bug.