This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 503907 - virt-manager auto-connect, xend not installed
virt-manager auto-connect, xend not installed
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 06:22 EDT by Dagan McGregor
Modified: 2009-08-18 10:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-18 10:34:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dagan McGregor 2009-06-03 06:22:55 EDT
Description of problem:
virt-manager lists xen hypervisor as an option to connect to, when xen is not installed. It tries to auto-connect to xen, causing an error each time virt-manager is opened

Version-Release number of selected component (if applicable):
Installed Packages
Name       : virt-manager
Arch       : x86_64
Version    : 0.6.0
Release    : 5.fc10
Size       : 4.5 M
Repo       : installed
Summary    : Virtual Machine Manager

How reproducible:
always

Steps to Reproduce:
1. install virt-manager
2. open virt-manager (as root)
3. read error message
  
Actual results:
Opening virt-manager displays an error message about xend not running to connect to.

Unable to open connection to hypervisor URI 'xen:///':
<class 'libvirt.libvirtError'> internal error failed to connect to xend
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 483, in _open_thread
    None], flags)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 99, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: internal error failed to connect to xend

Expected results:
virt-manager should auto-detect whether xen or kvm is installed, and only provide option to connect to hypervisors that are installed.

Additional info:
kvm is installed, and virt-manager auto-connects to localhost/qemu (kvm in disguise).
auto-connect to hypervisor host option seems to be a default.

The only xen related package installed is xen-libs, which seems to be a dependancy somewhere along the way with libvirt or related packages.

Installed Packages
Name       : kvm
Arch       : x86_64
Version    : 74
Release    : 10.fc10
Size       : 2.1 M
Repo       : installed
Summary    : Kernel-based Virtual Machine

Installed Packages
Name       : xen-libs
Arch       : x86_64
Version    : 3.3.0
Release    : 1.fc10
Size       : 351 k
Repo       : installed
Summary    : Libraries for Xen tools
Comment 1 Cole Robinson 2009-06-16 15:20:38 EDT
If you delete all connections from the virt-manager list, and the restart the app, does the xen connection reappear, or a qemu one? (or none)?

Also, you can stop the auto connection attempt by going to Edit->Conn Details, and uncheck autoconnect.
Comment 2 Dagan McGregor 2009-06-17 02:22:46 EDT
 Once I deleted the Xen entry, it didn't return. I still have the QEMU (KVM) entry, as I have two virtual machines created there.

 And yes, I turned off the auto-connect for Xen before deleting the entry.
Comment 3 Dagan McGregor 2009-08-18 01:11:53 EDT
This bug can possibly be closed now, as I have upgraded to F11, and cannot do any further testing. 

 As noted above, after unchecking the autoconnect to Xen, the error did stop.
Comment 4 Mark McLoughlin 2009-08-18 10:34:15 EDT
Thanks Dagan

Note You need to log in before you can comment on or make changes to this bug.