Bug 504015 - el4 builds for rhn-java packages fail on brew for 5.2 satellite
el4 builds for rhn-java packages fail on brew for 5.2 satellite
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
520
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Brandon Perkins
: Reopened
Depends On:
Blocks: 473867
  Show dependency treegraph
 
Reported: 2009-06-03 15:46 EDT by Pradeep Kilambi
Modified: 2009-10-19 10:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-19 10:04:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2009-06-03 15:46:16 EDT
Description of problem:
Package: rhn-java-sat-5.2.0-44.hotfix_502259.el4
Tag: satellite-4E-5.2-candidate
Status: failed
Built by: pkilambi
ID: 88601
Started: Wed, 03 Jun 2009 15:35:41 EDT
Finished: Wed, 03 Jun 2009 15:41:34 EDT


rhn-java-sat-5.2.0-44.hotfix_502259.el4 (88601) failed on ls20-bc2-14.build.redhat.com (x86_64), bullwinkle.build.redhat.com (noarch):
  BuildError: error building package (arch noarch), mock exited with status 30; see root.log for more information
SRPMS:
  rhn-java-sat-5.2.0-44.hotfix_502259.el4.src.rpm

Failed tasks:
-------------

Task 1826307 on ls20-bc2-14.build.redhat.com
Task Type: buildArch (rhn-java-sat-5.2.0-44.hotfix_502259.el4.src.rpm, noarch)
logs:
  https://brewweb.devel.redhat.com//getfile?taskID=1826307&name=build.log
  https://brewweb.devel.redhat.com//getfile?taskID=1826307&name=root.log
  https://brewweb.devel.redhat.com//getfile?taskID=1826307&name=state.log

Task 1826294 on bullwinkle.build.redhat.com
Task Type: build (satellite-4E-5.2-candidate, /cvs/dist:rpms/rhn-java-sat/RHEL-4-RHNSAT-5_2:rhn-java-sat-5_2_0-44_hotfix_502259_el4)


Closed tasks:
-------------

Task 1826296 on hs20-bc1-7.build.redhat.com
Task Type: buildSRPMFromSCM (/cvs/dist:rpms/rhn-java-sat/RHEL-4-RHNSAT-5_2:rhn-java-sat-5_2_0-44_hotfix_502259_el4)
logs:
  https://brewweb.devel.redhat.com//getfile?taskID=1826296&name=build.log
  https://brewweb.devel.redhat.com//getfile?taskID=1826296&name=checkout.log
  https://brewweb.devel.redhat.com//getfile?taskID=1826296&name=root.log
  https://brewweb.devel.redhat.com//getfile?taskID=1826296&name=state.log


Additional info:

el5 builds work fine btw. So looks like some deps are missing on the build box?

from https://brewweb.devel.redhat.com//getfile?taskID=1826296&name=root.log

...
DEBUG backend.py:562:  /usr/bin/yum --installroot /var/lib/mock/satellite-4E-5.2-build-514699-129478/root/  install  'struts' 'bouncycastle' 'jpam' 'jdom' 'ant' 'cglib' 'rhn-oracle-jdbc >= 0:1.0-10' 'ivy' 'oscache' 'dom4j' 'jakarta-taglibs-standard' 'jakarta-commons-fileupload' 'antlr >= 0:2.7.6' 'ant-contrib' 'java-devel = 1.5.0' 'tanukiwrapper' 'quartz' 'redstone-xmlrpc' 'jakarta-commons-el' 'jasper5' 'ant-apache-regexp' 'c3p0' 'concurrent' 'sitemesh' 'jakarta-commons-configuration' 'asm' 'bouncycastle-jdk1.5' 'ehcache' 'ant-nodeps' 'xdoclet' 'ant-junit' 'wsdl4j' 'hibernate3' 'jakarta-commons-discovery' 'jakarta-commons-io' 'jcommon' 'jfreechart' 'jakarta-commons-validator'
DEBUG util.py:280:  Executing command: /usr/bin/yum --installroot /var/lib/mock/satellite-4E-5.2-build-514699-129478/root/  install  'struts' 'bouncycastle' 'jpam' 'jdom' 'ant' 'cglib' 'rhn-oracle-jdbc >= 0:1.0-10' 'ivy' 'oscache' 'dom4j' 'jakarta-taglibs-standard' 'jakarta-commons-fileupload' 'antlr >= 0:2.7.6' 'ant-contrib' 'java-devel = 1.5.0' 'tanukiwrapper' 'quartz' 'redstone-xmlrpc' 'jakarta-commons-el' 'jasper5' 'ant-apache-regexp' 'c3p0' 'concurrent' 'sitemesh' 'jakarta-commons-configuration' 'asm' 'bouncycastle-jdk1.5' 'ehcache' 'ant-nodeps' 'xdoclet' 'ant-junit' 'wsdl4j' 'hibernate3' 'jakarta-commons-discovery' 'jakarta-commons-io' 'jcommon' 'jfreechart' 'jakarta-commons-validator'
DEBUG util.py:256:  xdoclet-1.2.3-7jpp.ep1.4.noarch from build has depsolving problems
DEBUG util.py:256:    --> Missing Dependency: xjavadoc = 1.1 is needed by package xdoclet-1.2.3-7jpp.ep1.4.noarch (build)
DEBUG util.py:256:  Error: Missing Dependency: xjavadoc = 1.1 is needed by package xdoclet-1.2.3-7jpp.ep1.4.noarch (build)
DEBUG util.py:319:  Child returncode was: 1
...
Comment 1 Jan Pazdziora 2009-10-13 09:47:01 EDT
The issue was addressed by change

$ svn log -c 186889
------------------------------------------------------------------------
r186889 | mmccune | 2009-09-08 23:17:35 +0200 (Tue, 08 Sep 2009) | 2 lines

RT Ticket 49248  - patch from dgilmore to fix build requires for el4

------------------------------------------------------------------------
$ svn diff -c 186889
Index: java/rhn-java.spec
===================================================================
--- java/rhn-java.spec	(revision 186888)
+++ java/rhn-java.spec	(revision 186889)
@@ -90,6 +90,12 @@
 BuildRequires: sitemesh
 BuildRequires: wsdl4j
 BuildRequires: xdoclet
+%if 0%{?rhel} == 4
+BuildRequires: tomcat5-jsp-2.0-api
+BuildRequires: servletapi5
+BuildRequires: geronimo-jta-1.0.1B-api
+%endif
+
 Obsoletes: rhn-java
 %description -n rhn-java-sat
 This package contains the code for the Java version of the Red Hat
$

Even if we might need more investigation about what happened since 5.2.0, as proposed in

http://post-office.corp.redhat.com/archives/satellite-dept-list/2009-October/msg00172.html

this issue is basically nonexistent now. As it's of operational nature and not about any of the code we have in Satellite 5.2 branches, closing as NOTABUG.
Comment 2 Jan Pazdziora 2009-10-19 04:13:40 EDT
The satellite-[45]E-5.2 tags were reconfigured to inherit from satellite-[45]E-5.2.0 first, to address other dependencyissues.

So we might actually have the same build environment as we had for 5.2.0 and the BuildRequires might not be needed anymore. Need to investigate.
Comment 3 Jan Pazdziora 2009-10-19 10:04:41 EDT
I've tried to build the rhn-java-sat package with the BuildRequires from revision 186889 reverted. However, I still get

+ ant -Dprefix=/var/tmp/rhn-java-sat-root install
Buildfile: build.xml
set-default-config-dir:
init-install:
boot-deps:
init-ivy:
resolve-ivy:
resolve-local:
    [mkdir] Created dir: /builddir/build/BUILD/rhn-java-sat-svn-r187990/build/build-lib
    [mkdir] Created dir: /builddir/build/BUILD/rhn-java-sat-svn-r187990/build/test-lib
    [mkdir] Created dir: /builddir/build/BUILD/rhn-java-sat-svn-r187990/build/run-lib/external
     [exec] /usr/bin/build-jar-repository: error: Could not find jspapi Java extension for this JVM
     [exec] /usr/bin/build-jar-repository: error: Some specified jars were not found for this jvm
BUILD FAILED

even on the 5.2.0-like repo. So, closing as having the BuildRequires there seems to be needed and no time for further investigation.

Note You need to log in before you can comment on or make changes to this bug.