Bug 504047 - kvm doesn't use native get_user_pages_fast()
kvm doesn't use native get_user_pages_fast()
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: john cooper
Lawrence Lim
:
Depends On: 504038
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 18:38 EDT by john cooper
Modified: 2014-07-24 23:45 EDT (History)
9 users (show)

See Also:
Fixed In Version: kvm-83-67.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 501777
Environment:
Last Closed: 2009-09-02 05:35:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kvm doesn't build on newer RHEL-5.4 kernels because of get_user_pages_fast(), AKA BZ #504047, V2 (3.37 KB, patch)
2009-06-04 17:22 EDT, Eduardo Habkost
no flags Details | Diff

  None (edit)
Comment 1 Eduardo Habkost 2009-06-04 17:22:15 EDT
Created attachment 346590 [details]
kvm doesn't build on newer RHEL-5.4 kernels because of get_user_pages_fast(), AKA BZ #504047, V2

Patch that is currently on the git patch queue.
Comment 2 Eduardo Habkost 2009-06-04 17:22:20 EDT
Patch posted for review and queued. Changing status to POST
http://post-office.corp.redhat.com/archives/virtualist/2009-June/msg00194.html
Comment 8 Eduardo Habkost 2009-06-09 13:31:29 EDT
Changing summary to something meaningful, making it depend on the kernel-side changes (bug #504038).
Comment 11 lihuang 2009-07-12 10:04:33 EDT
kvm-83-82.el5 already included in RHEL5u4 beta.(kernel-2.6.18-156.el5)
Comment 13 errata-xmlrpc 2009-09-02 05:35:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1272.html

Note You need to log in before you can comment on or make changes to this bug.