Bug 50408 - During NFS install, Anaconda terminates with error message, round about the disk format (I think - it was several days ago!).
During NFS install, Anaconda terminates with error message, round about the d...
Status: CLOSED DUPLICATE of bug 34128
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-30 19:56 EDT by Mark Gooch
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-30 19:57:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error file from Anaconda (6.36 KB, text/plain)
2001-07-30 19:57 EDT, Mark Gooch
no flags Details

  None (edit)
Description Mark Gooch 2001-07-30 19:56:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)

Description of problem:
Doing an NFS install on two systems, a 486 system (IBM PS/ValuePoint)
433DX/Si, with 16Mbytes & an ISA network card (NE2000 compatible, Mentor
model PTC-1004PP), and on a Pentium system (Compaq Prolinea 575e) Pentium
75, 24Mbytes, PCI network card. Problem occured at same point in
installation, with same error message. Installing from CDs from
CheepLinux3, product code P/N CL147P.
Problem did not occur on local install on a (more modern) Pentium 233
machine with 96Mbytes RAM (which was the NFS server)

How reproducible:
Always

Steps to Reproduce:
1.NFS boot from CD (CD specifically for remote install)
2.Select English lang, UK keyboard, no mouse, format disc with Fdisk to
have  swap & / partitions
3.Note - reproducible on two different hardware platforms.
	

Actual Results:  Installation script terminated with error message (shown
below) around the disk format (disk partition information was at least
partially written, old partition information was erased)

Expected Results:  Installation script should have continued normally

Additional info:

Error report from Anaconda, typed in:

Traceback (innermost last):
 File "/usr/bin/anaconda", line 438, in ?
  intf.run(todo, test = test)
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
  rc = apply (step[1](), step[2])
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py",
line 32, in __call__
  todo.getHeaderList()
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 532, in
getHeaderList()
  self.hdList = self.method.readHeaders()
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 22, in
readHeaders      return HeaderListFromFile(self.tree +
"/RedHat/base/hdlist")
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 136, in
__init__
  hdlist = rpm.readHeaderListFromFile(path)
rpm.error: (2, 'No such file or directory')

Local variables in innermost frame:
compatPackages: None
self: <comps.HeaderListFromFile instance at 820c490>
path: /mnt/source/./RedHat/base/hdlist


At no point in the NFS installation was I able to use the <Ctrl> <Alt> F2
sequence to gain access to a shell. <Ctrl> <Alt> F3 and <Ctrl> <Alt> F4
worked. As a result I was not able to get any further data on the problem.
Comment 1 Mark Gooch 2001-07-30 19:57:23 EDT
Created attachment 25511 [details]
Error file from Anaconda
Comment 2 Brent Fox 2001-08-06 11:31:58 EDT
I think that you have a bad cd.  This is a dupe of bug #34128

*** This bug has been marked as a duplicate of 34128 ***

Note You need to log in before you can comment on or make changes to this bug.