Bug 504091 - QXL: X cannot start with installed qxl driver
QXL: X cannot start with installed qxl driver
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-qxl (Show other bugs)
5.4
All Linux
high Severity urgent
: rc
: ---
Assigned To: Søren Sandmann Pedersen
: TestBlocker
: 507884 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 03:09 EDT by Vladik Romanovsky
Modified: 2014-06-18 05:11 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:57:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log file and xorg.conf (6.91 KB, application/octetstream)
2009-06-04 03:09 EDT, Vladik Romanovsky
no flags Details
xorg log with HorizSync 24-82 (9.95 KB, text/plain)
2009-06-25 08:49 EDT, Vladik Romanovsky
no flags Details
qxl log for xorg-x11-drv-qxl-0.0.3-1.2.el5.x86_64 from shell.devel (42.94 KB, application/octet-stream)
2009-07-01 05:20 EDT, Vladik Romanovsky
no flags Details
xorg.r1.conf (574 bytes, text/plain)
2009-08-04 07:12 EDT, Yan Tian
no flags Details
Xorg.0.r1.log (9.15 KB, text/plain)
2009-08-04 07:12 EDT, Yan Tian
no flags Details
Xorg.0.r2.log (9.05 KB, text/plain)
2009-08-04 07:13 EDT, Yan Tian
no flags Details
Xorg.0.r3.log (9.05 KB, text/plain)
2009-08-04 07:13 EDT, Yan Tian
no flags Details

  None (edit)
Description Vladik Romanovsky 2009-06-04 03:09:15 EDT
Created attachment 346496 [details]
xorg log file and xorg.conf

X cannot start with installed QXL driver (0.0.3-1.2) on 64bit client/server RHEL5.3 machine, with the attached xorg.conf

I have tried to change the HorizSync, but 24-100 was the only configuration  without any range errors in the log.

Please see the attached log.

Thanks.
Comment 2 Søren Sandmann Pedersen 2009-06-24 07:35:03 EDT
Which version of kvm were you using?

Also, what is the output of lspci -v (as root)?
Comment 3 Søren Sandmann Pedersen 2009-06-24 07:39:42 EDT
Also, if you do set HorizSync to 24-82, what exactly happens? Can you attach the log in that case (please don't zip it).

I suspect there may be an inadvertent dependency on something else that changed in 5.4, but I'm not sure what.
Comment 4 Vladik Romanovsky 2009-06-25 08:49:49 EDT
Created attachment 349391 [details]
xorg log with HorizSync 24-82
Comment 5 Vladik Romanovsky 2009-06-25 08:50:34 EDT
Soren,

The kvm is a part of RHEV 2.1 beta - 83-69

lspci -v:
00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
        Subsystem: Qumranet, Inc. Unknown device 1100
        Flags: fast devsel

00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
        Subsystem: Qumranet, Inc. Unknown device 1100
        Flags: bus master, medium devsel, latency 0

00:01.1 RAM memory: Qumranet, Inc. Unknown device 0200
        Subsystem: Qumranet, Inc. Unknown device 1100
        Flags: fast devsel, IRQ 10
        I/O ports at c000 [size=256]

00:01.2 IDE interface: Intel Corporation 82371SB PIIX3 IDE [Natoma/Triton II] (prog-if 80 [Master])
        Subsystem: Qumranet, Inc. Unknown device 1100
        Flags: bus master, medium devsel, latency 64
        I/O ports at c100 [size=16]

00:01.3 USB Controller: Intel Corporation 82371SB PIIX3 USB [Natoma/Triton II] (rev 01) (prog-if 00 [UHCI])
        Subsystem: Qumranet, Inc. Unknown device 1100
        Flags: bus master, fast devsel, latency 64, IRQ 11
        I/O ports at c120 [size=32]

00:01.4 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
        Subsystem: Qumranet, Inc. Unknown device 1100
        Flags: medium devsel, IRQ 9

00:02.0 Communication controller: Red Hat, Inc. Unknown device 0105 (rev 01)
        Subsystem: Qumranet, Inc. Unknown device 1100
        Flags: fast devsel, IRQ 10
        I/O ports at c140 [size=16]
        Memory at c1000000 (32-bit, non-prefetchable) [size=64K]

00:03.0 VGA compatible controller: Red Hat, Inc. Unknown device 0100 (rev 01) (prog-if 00 [VGA controller])
        Subsystem: Qumranet, Inc. Unknown device 1100
        Flags: bus master, fast devsel, latency 0, IRQ 11
        Memory at c4000000 (32-bit, non-prefetchable) [size=64M]
        Memory at c8000000 (32-bit, prefetchable) [size=4K]
        Memory at c8002000 (32-bit, non-prefetchable) [size=8K]
        I/O ports at c150 [size=8]

00:04.0 Ethernet controller: Qumranet, Inc. Virtio network device
        Subsystem: Qumranet, Inc. Unknown device 0001
        Flags: fast devsel, IRQ 11
        I/O ports at c160 [size=32]

00:05.0 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev 01)
        Subsystem: Intel Corporation Unknown device 0000
        Flags: bus master, medium devsel, latency 64, IRQ 10
        I/O ports at c400 [size=1K]
        I/O ports at c800 [size=256]

I can provide you a direct access to this VM, you can ping me at #seg-team or #gss-rhev

Vladik
Comment 8 Søren Sandmann Pedersen 2009-06-30 21:58:22 EDT
Please set the flags such that I can make changes to the source code.
Comment 9 Søren Sandmann Pedersen 2009-06-30 22:01:43 EDT
I built some packages locally. They are available on shell.devel.redhat.com in 

    /home/boston/sandmann/xorg-x11-drv-qxl-0.0.3-1.2.el5.x86_64.rpm
Comment 10 Vladik Romanovsky 2009-07-01 05:20:25 EDT
Created attachment 350074 [details]
qxl log for xorg-x11-drv-qxl-0.0.3-1.2.el5.x86_64 from shell.devel

I have reinstalled the xorg-x11-drv-qxl-0.0.3-1.2.el5.x86_64 from the shell.devel.
The X has failed again.
Please see the attached log.

Thanks,

Vladik
Comment 11 Søren Sandmann Pedersen 2009-07-01 10:11:57 EDT
Failed in what way?

Also, please try with the original xorg.conf file.
Comment 12 Vladik Romanovsky 2009-07-01 12:19:27 EDT
Soren, 

I did check that both with the original xorg.conf and with the one you have sent me. In both cases the result is the same, the X cannot start, then it asks if i want to reconfigure the Xorg and once i set the defaults, it starts again.

I have made an attachment with the failed xorg.log:
https://bugzilla.redhat.com/attachment.cgi?id=350074

Vladik
Comment 13 Søren Sandmann Pedersen 2009-07-01 14:40:16 EDT
It starts for me on a RHEL 5.3 guest.  Can you make the guest image that you are using available?
Comment 14 Søren Sandmann Pedersen 2009-07-01 15:54:16 EDT
I have uploaded new driver packages:

    xorg-x11-drv-qxl-0.0.4-1.1.el5.x86_64.rpm

I have verified that these start for me and I can run an xterm in them.

If they don't work for you, please let me know what happens if you do this:

   - boot in runlevel 3
   - ssh into the guest
   - run 

        Xorg :0.0 -ac

     as root.

What, if anything does it print?
Comment 15 Vladik Romanovsky 2009-07-02 09:02:13 EDT
Soren,

Great, this one is working! 

However, there are some issues with mouse in the guest.

Thanks!!

Vladik
Comment 16 Jonathan Blandford 2009-07-02 17:57:08 EDT
If that's the case, can you file a new bug so that we can get this fix in.
Comment 19 Søren Sandmann Pedersen 2009-07-15 16:18:48 EDT
*** Bug 507884 has been marked as a duplicate of this bug. ***
Comment 20 Leonid Natapov 2009-07-20 10:40:23 EDT
sp169
Comment 22 Yan Tian 2009-08-04 07:12:09 EDT
Created attachment 356146 [details]
xorg.r1.conf
Comment 23 Yan Tian 2009-08-04 07:12:34 EDT
Created attachment 356147 [details]
Xorg.0.r1.log
Comment 24 Yan Tian 2009-08-04 07:13:01 EDT
Created attachment 356148 [details]
Xorg.0.r2.log
Comment 25 Yan Tian 2009-08-04 07:13:35 EDT
Created attachment 356149 [details]
Xorg.0.r3.log
Comment 26 Leonid Natapov 2009-08-04 08:26:46 EDT
you can close this bug.
Works with driver 0.0.4-1.1
Comment 27 Yan Tian 2009-08-04 08:32:45 EDT
Changed the bug status back VERIFIED according to Comment #26.
Comment 28 Leonid Natapov 2009-08-04 08:47:25 EDT
I am using xorg-x11-drv-qxl-0.0.4-1.1.el5.x86_64.rpm for RHEL Server 64 bit.
sp176 and it works.

Yan,are you using the same driver and the same OS ?
Comment 29 Yan Tian 2009-08-04 09:26:28 EDT
(In reply to comment #28)
> I am using xorg-x11-drv-qxl-0.0.4-1.1.el5.x86_64.rpm for RHEL Server 64 bit.
> sp176 and it works.
> 
> Yan,are you using the same driver and the same OS ?  

Yes, it's same.
Comment 30 Leonid Natapov 2009-08-04 09:30:56 EDT
After installing RPM you should run system-config-display ,go to display section and choose QXL driver and than restart the X. Is this what you do ?
Comment 31 Yan Tian 2009-08-04 23:17:15 EDT
(In reply to comment #30)
> After installing RPM you should run system-config-display ,go to display
> section and choose QXL driver and than restart the X. Is this what you do ?  

It worked for me with following steps:
- installed xorg-x11-drv-qxl-0.0.4-1.1.el5.x86_64.rpm for RHEL5.4 Server x86_64 guest
- ran system-config-desplay to change video card driver to QXL
- log out - showed blue screen with info "failed to start the X server..."
- login console and startx
- X start

Thanks for your guide, Leonid.
Comment 33 errata-xmlrpc 2009-09-02 05:57:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1308.html

Note You need to log in before you can comment on or make changes to this bug.