Bug 504107 - CUPS won't connect to network
CUPS won't connect to network
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 05:19 EDT by Skippy
Modified: 2009-06-17 15:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-04 08:57:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of `strace lpstat` (39.29 KB, application/octet-stream)
2009-06-04 07:51 EDT, Skippy
no flags Details

  None (edit)
Description Skippy 2009-06-04 05:19:01 EDT
Description of problem:
CUPS won't see shared printers. My computer is on a LAN with an IPP server which used to work and still works correctly on other computers. The cups service is launched on my machine. However, system-config-printer says it's not, and the connection fails with "httpConnectionEncrypt failed". http://127.0.0.1:631 won't find any printer, and cupsdconf fails also to launch.

Additional informations:
/etc/cups/cups.conf: http://pastebin.com/f1fccddc6
/var/log/cups/error_log: http://pastebin.com/m6407ddff
/etc/cups/client.conf: ServerName nameoftheserver

cupsdconf errors ===========================================
# cupsdconf
Session management error: None of the authentication protocols specified are supported
Session management error: None of the authentication protocols specified are supported
kbuildsycoca running...
Session management error: None of the authentication protocols specified are supported
OggS-SEEK: at 704 want 47096 got 23104 (diff-requested 46392)
OggS-SEEK: at 47040 want 1032 got 0 (diff-requested -46008)
======================================================

system-config-printer errors ====================================
Traceback:
File "/usr/share/system-config-printer/troubleshoot/__init__.py", line 288, in _collect_answer
    return question.collect_answer ()
File "/usr/share/system-config-printer/troubleshoot/Welcome.py", line 53, in collect_answer
    return { '_authenticated_connection': authconn.Connection (parent) }
File "/usr/share/system-config-printer/authconn.py", line 115, in __init__
    self._connect ()
File "/usr/share/system-config-printer/authconn.py", line 129, in _connect
    encryption=self._encryption)
RuntimeError: httpConnectionEncrypt failed
======================================================


Version-Release number of selected component (if applicable):
Appeared a few days ago, upgrading to 1.3.10-5 didn't help.
Comment 1 Tim Waugh 2009-06-04 05:42:13 EDT
I need more information:

Which version of Fedora are you using on the machine you run system-config-printer on?

Which operating system and version are you running on the "IPP server", i.e. the 'nameoftheserver' machine, the one you've specified in /etc/cups/client.conf on the Fedora machine?
Comment 2 Skippy 2009-06-04 05:53:06 EDT
I'm running an uptodate Fedora 10.

Concerning the IPP server, according to nmap :
Running: Emprex Linux 2.6.X, Infoblox NIOS 4.X, Linux 2.4.X|2.6.X, Tandberg Linux 2.6.X
Too many fingerprints match this host to give specific OS details
Comment 3 Skippy 2009-06-04 05:56:45 EDT
Sorry, reading nmap manual helped : do not restrict yourself to one port when trying to find OS version…

So, IPP server :
Running: Linux 2.4.X
OS details: Linux 2.4.21 - 2.4.33
Comment 4 Tim Waugh 2009-06-04 06:13:53 EDT
Thanks.  How about the other computers that are successfully using the IPP server, what are they running?
Comment 5 Skippy 2009-06-04 06:26:30 EDT
Mac OSX, Ubuntu, Fedora Core 4 and other various linux distributions. And I was successfully using it as well up to last week, then took my laptop at home, and when I came back it didn't work anymore.
Comment 6 Tim Waugh 2009-06-04 06:41:05 EDT
OK, thanks.  Can you please run this command:

strace lpstat -s 2>lpstat.log

and attach the lpstat.log file?  Thanks. (You'll need to install the 'strace' package if you don't already have it.)
Comment 7 Skippy 2009-06-04 07:51:00 EDT
Created attachment 346520 [details]
output of `strace lpstat`

output of `strace lpstat`
Comment 8 Tim Waugh 2009-06-04 08:46:52 EDT
It's trying to connect to 193.48.86.77 on port 631 -- is that the correct IP address?
Comment 9 Skippy 2009-06-04 08:51:02 EDT
Yes, this is the correct address.
Comment 10 Tim Waugh 2009-06-04 08:57:15 EDT
Then the problem is on the remote end. (You might want to double-check that the other machines are using the same IP address and port number.)
Comment 11 Skippy 2009-06-04 09:25:07 EDT
I doubt it. I just tried (both by editing client.conf and from system-config-server) with another server which is actually successfully used by a colleague, and there is no improvement.

Moreover, I don't understand how system-config-printer can say cups is not running while it IS. As a consequence, almost all buttons of system-config-printer are disabled, and I cannot even add a printer. All I can do is trying to connect without success to some server.
Comment 12 Tim Waugh 2009-06-04 10:37:49 EDT
You have told all CUPS clients (including system-config-printer) on that machine to completely disregard any local cupsd by putting a 'ServerName' line in client.conf -- this means that they go straight to whichever machine you've specified, and not to the local machine.

You don't want to do this unless the specified machine is a CUPS server (which it might/might not be, I can't tell).

But I can see that the Fedora machine attempts to connect and the connection is refused by the remote machine.  There's nothing more than can be done about it.

Perhaps there is a firewall on the remote machine, or something like that.  In any case, the connection is refused, and this is not something under our control.
Comment 13 Skippy 2009-06-04 10:51:17 EDT
(In reply to comment #12)
> You have told all CUPS clients (including system-config-printer) on that
> machine to completely disregard any local cupsd by putting a 'ServerName' line
> in client.conf -- this means that they go straight to whichever machine you've
> specified, and not to the local machine.

Ok, this is far more clear now, thanks for this explanation.

Sorry for the inconvenience, I will check if my IP has changed and with the network admins if there have been changes on the servers configuration.
Comment 14 Skippy 2009-06-17 15:39:34 EDT
For the records : I was trying to add LPD servers as IPP ones… -_-'

Cannot understand how my config changed from one day to the other though. But anyways. Sorry for the trouble.

Note You need to log in before you can comment on or make changes to this bug.