Bug 504136 - Add support for PackageKit service packs
Add support for PackageKit service packs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 08:24 EDT by Rahul Sundaram
Modified: 2013-03-13 01:45 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-28 16:40:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2009-06-04 08:24:06 EDT
Description of problem:

PackageKit has the ability to create what is called service packs used for offline software installation. These are basically tar balls 

# file netbeans-fedora-11-i686.servicepack 
netbeans-fedora-11-i686.servicepack: POSIX tar archive

Ark should recognize and be able to extract files with this extension.
Comment 1 Rex Dieter 2009-06-04 09:20:19 EDT
Feature requests probably best sent upstream, but we'll do what we can.
Comment 2 Kevin Kofler 2009-06-04 09:26:35 EDT
I think the RFE here was just for Ark to treat .servicepack as a tarball. I agree KPackageKit needs support for them too.
Comment 3 Rahul Sundaram 2009-06-04 09:34:54 EDT
Yes. Kevin Kofler is correct. This was wrongly reassigned to KPackageKit.
Comment 4 Rex Dieter 2009-06-04 09:35:25 EDT
sorry, my bad for not reading the original report careful enough.
Comment 5 Rex Dieter 2009-06-04 09:56:56 EDT
Looks like ark "just works" if the
application/x-servicepack
is added to ark.desktop's
MimeType=...

Now, to decide if we want this to be preferred over packagekit's or not (testing kpk support here)
Comment 6 Rex Dieter 2009-06-04 10:01:40 EDT
kpk doesn't seem to support it, but that may be related to bug #499690
Comment 7 Richard Hughes 2009-06-04 10:36:37 EDT
It should be a trivial patch to KPackageKit to enable this functionality.
Comment 8 Rex Dieter 2009-06-04 11:25:11 EDT
OK, support added to kdeutils-4.2.4-2 and kdeutils-4.2.90-1
Comment 9 Steven M. Parrish 2009-06-28 16:11:21 EDT
Rex, I know we have a fix for this based on the mimetype but do you want me to send this up to KPK and get it integrated there?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Rex Dieter 2009-06-28 16:40:01 EDT
The only fix I'm aware of is for kdeutils/ark (for which I just sent upstream).

So, whatever can be done to help on the kpackagekit end of things, I'm all for it.

Note You need to log in before you can comment on or make changes to this bug.