Bug 504179 - system-config-netboot - add /var/db/ to the list of default directories added to the snapshot/files
system-config-netboot - add /var/db/ to the list of default directories added...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-netboot (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jaroslav Reznik
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 12:01 EDT by ritz
Modified: 2013-04-12 16:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-25 04:37:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ritz 2009-06-04 12:01:24 EDT
Description of problem:
We are using LDAP as directory service on our machines.
This also applies to our diskless clients.

We experienced all sorts of very strange effects with this when
nscd would not run on our diskless clients (I don't know whether
we would see the same effects in clients with a local disk image).

It turned out that nscd would not run because /var/db/ was mounted
read-only from the NFS server.
Adding this directory to snapshot/files.custom and rebooting the
diskless clients solved the problem.

I would like to suggest adding /var/db/ to the list of default directories
added to the snapshot/files file by system-config-netboot.



Steps to reproduce:
Set up a diskless client according to the system-config-netboot docs:
https://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/sysadmin-guide/s1-diskless-hosts.html
Boot up the diskless client, and try to use LDAP.


Actual results:
nscd fails to start and LDAP doesn't function properly.

Expected results:
Diskless systems should be able to use LDAP without any additional configuration.

Workaround:
Customer was able to work around this by adding /var/db to snapshot/files.custom in the root/ directory.  


Additional info:

This would help make life easier on admins that have to set up diskless systems in an LDAP environment.
Comment 2 RHEL Product and Program Management 2009-11-06 14:21:26 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 errata-xmlrpc 2011-05-25 04:37:51 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0829.html

Note You need to log in before you can comment on or make changes to this bug.