Bug 50419 - CVS rpm 4.0.3 compile failure on Solaris
Summary: CVS rpm 4.0.3 compile failure on Solaris
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 1.0
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-31 02:00 UTC by Red Hat Bugzilla
Modified: 2008-03-13 19:18 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-31 03:00:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm-4.0.3/lib/hdrinline.h "void functions return something" patch (1.46 KB, patch)
2001-07-31 02:01 UTC, Red Hat Bugzilla
no flags Details | Diff

Description Red Hat Bugzilla 2001-07-31 02:00:08 UTC
rpm 4.0.3 from CVS (as of 6:00 pm CDT 07/30/2001) fails to compile on
Solaris with
the Sun Forte development environment, version 6.1.

The problem is that several functions in rpm-4.0.3/lib/hdrinline.h have
void return types,
but actually try return a value.  gcc might say "whatever", but most other
compilers will
rightfully object.

A patch is attached, though JBJ may find a better fix than just deleting
the three
inlined versions of those functions.

Comment 1 Red Hat Bugzilla 2001-07-31 02:01:34 UTC
Created attachment 25531 [details]
rpm-4.0.3/lib/hdrinline.h "void functions return something" patch

Comment 2 Red Hat Bugzilla 2001-07-31 03:00:12 UTC
This appears to be a problem with
	return (void)
that can be easily remedied with s/return //. Will do ...

Comment 3 Red Hat Bugzilla 2001-08-04 18:12:27 UTC
FIxed in my next checkin, should be in rpm-4.0.3-0.87.


Note You need to log in before you can comment on or make changes to this bug.