Bug 50421 - X 4.1.0 segfaults when loading libramdac.a module.
Summary: X 4.1.0 segfaults when loading libramdac.a module.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-31 02:15 UTC by Sam Varshavchik
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 02:33:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86.0.log of X 4.1.0 crashing after loading libramdac.a (17.03 KB, text/plain)
2001-07-31 02:17 UTC, Sam Varshavchik
no flags Details
XF86Config-4 (2.35 KB, text/plain)
2001-07-31 02:17 UTC, Sam Varshavchik
no flags Details
A working XF86Config for 3.3.6 (15.22 KB, text/plain)
2001-07-31 02:19 UTC, Sam Varshavchik
no flags Details
chipset (1.63 KB, text/plain)
2001-07-31 02:20 UTC, Sam Varshavchik
no flags Details
libramdac.a appears to make some additional progress before segfaulting. (17.22 KB, text/plain)
2001-09-12 21:43 UTC, Sam Varshavchik
no flags Details

Description Sam Varshavchik 2001-07-31 02:15:16 UTC
Xconfigurator defaults to X 3.3.6 for the following chipset, due to some
minor display corruption in X 4.0's "chips" driver.  But if I wanted to, I
was always able to run X 4.0 with the following chipset.  It worked fine,
except for some minor display corruption.

Starting with 4.1, X fails to start no matter what.  I've tried multiple
resolutions, and depths, the end result is always the same - a segfault
after loading libramdac.a

3.3.6 in beta3 still works fine for this chipset.  The problem is the 4.1
regression.

Comment 1 Sam Varshavchik 2001-07-31 02:17:03 UTC
Created attachment 25532 [details]
XFree86.0.log of X 4.1.0 crashing after loading libramdac.a

Comment 2 Sam Varshavchik 2001-07-31 02:17:59 UTC
Created attachment 25533 [details]
XF86Config-4

Comment 3 Sam Varshavchik 2001-07-31 02:19:09 UTC
Created attachment 25534 [details]
A working XF86Config for 3.3.6

Comment 4 Sam Varshavchik 2001-07-31 02:20:41 UTC
Created attachment 25535 [details]
chipset

Comment 5 Mike A. Harris 2001-08-01 02:26:52 UTC
Thanks for the detailed report mrsam, with all the attachments!  I will
diff the two trees and see if there are any changes that might have
caused this regression.  Thanks again for the complete report!


Comment 6 Sam Varshavchik 2001-08-02 00:14:02 UTC
Well, the only thing I can get with gdb is this:

...

(II) Module ramdac: vendor="The XFree86 Project"
	compiled for 4.1.0, module version = 0.1.0
(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x084c4b5a in ?? () at eval.c:41
41
eval.c: No such file or directory.
	in eval.c
(gdb) where
#0  0x084c4b5a in ?? () at eval.c:41
#1  0x080c4463 in AddScreen () at eval.c:41
#2  0x0806e0c2 in InitOutput () at eval.c:41
#3  0x080c3a22 in main () at eval.c:41
#4  0x4007d18e in __libc_start_main (main=0x80c3750 <main>, argc=1, 
    ubp_av=0xbffffb04, init=0x806c2d8 <_init>, fini=0x817ebb0 <_fini>, 
    rtld_fini=0x4000cf08 <_dl_fini>, stack_end=0xbffffafc)
    at ../sysdeps/generic/libc-start.c:129


Comment 7 Sam Varshavchik 2001-08-22 02:39:05 UTC
3.3.6 doesn't work any more in roswell2, because of an issue with xfs.



Comment 8 Mike A. Harris 2001-09-02 18:25:01 UTC
The xfs issue has been long since fixed.

Comment 9 Sam Varshavchik 2001-09-12 21:42:14 UTC
libramdac.a still segfaults in enigma.

Comment 10 Sam Varshavchik 2001-09-12 21:43:09 UTC
Created attachment 31698 [details]
libramdac.a appears to make some additional progress before segfaulting.

Comment 11 Mike A. Harris 2002-01-23 16:15:53 UTC
Lots of chips driver fixes went into XFree86 4.2.0.  I recommend
trying out my RHL 7.2 build of 4.2.0 located at:

ftp://people.redhat.com/mharris/testing/7.2/XFree86

I do not have this hardware for testing, nor its documentation, however
the new release may fix it.  Please update the bug report with the
latest info.

Comment 12 Sam Varshavchik 2002-01-24 02:33:31 UTC
This bug is fixed in 4.2 (other bugs from 4.0 are still there, though :-( ).




Note You need to log in before you can comment on or make changes to this bug.