Bug 504272 - [Fonts-Indic][te_IN] - Character 'HA' showing wrong shape in Composition
[Fonts-Indic][te_IN] - Character 'HA' showing wrong shape in Composition
Status: CLOSED DUPLICATE of bug 504270
Product: Fedora
Classification: Fedora
Component: lohit-telugu-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-05 06:38 EDT by Satyabrata Maitra
Modified: 2009-09-16 06:30 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-16 06:30:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proper Image Shape of 0C39 - HA. (2.27 KB, image/jpeg)
2009-06-05 06:38 EDT, Satyabrata Maitra
no flags Details

  None (edit)
Description Satyabrata Maitra 2009-06-05 06:38:16 EDT
Created attachment 346638 [details]
Proper Image Shape of 0C39 - HA.

Description of problem:
Telugu Character 'HA' (0C39) showing wrong shape when composed with another consonant as a below-base character.

One of the example is : U+0C28 U+0C4D U+0C39 (there are many like this)

The nearest hand-drawn shape image is attached here for primary reference.

Version-Release number of selected component (if applicable):
lohit-telugu-fonts-2.3.8-1.fc11
pango-1-24.1-1.fc11

How reproducible:
Always

Steps to Reproduce:
1. Start system with FC11 or Latest
2. Change the ibus with RAWCODE
3. Open Gedit
4. Type the combination's Unicode as given above.
5. Observe the lower part of the composed character.
  
Actual results:
Its wrongly showing.

Expected results:
It should be like the image attached here!

Additional info:  See the attachment.
Comment 1 Bug Zapper 2009-06-09 13:07:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Satyabrata Maitra 2009-06-29 03:10:51 EDT
Hi Jens

Is this bug now again assigned to rahul? I see some info like this, in history where his gmail id has been given. Just curious! :)

Satya
Comment 4 Pravin Satpute 2009-08-19 01:17:46 EDT
Satyabrata,

I will work on this, adding krishnababu in cc


Krishababu,

can you please update me on this with respect to lohit-telugu-fonts
Comment 5 Krishna Babu K 2009-08-19 02:44:06 EDT
Hi Pravin,

 As Satya said the 0C39 - HA(హ) is been showing wrong shape when composed with another consonant or with the same consonant as a below-base character.

 And he has mentioned the version-release number of lohit-telugu-fonts. Please let me know if you require any other information.

thanks,
Krishnababu.
Comment 6 Pravin Satpute 2009-09-16 06:30:43 EDT
same issue is addressed in bug 504270 as well so closing as a DUPLICATE

*** This bug has been marked as a duplicate of bug 504270 ***

Note You need to log in before you can comment on or make changes to this bug.