Bug 504282 - Update libxcb to version 1.3
Update libxcb to version 1.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xcb-proto (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-05 08:42 EDT by Michal Nowak
Modified: 2013-03-07 21:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 17:00:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2009-06-05 08:42:25 EDT
Description of problem:

Building of xcb-util-0.3.5 failed due to libxcb not being compiled with xcb-proto-1.5:

[...]
checking pkg-config is at least version 0.9.0... yes
checking for XCB... yes
checking for gawk... (cached) gawk
checking whether libxcb was compiled against xcb-proto >= 1.5... no
configure: error: libxcb was compiled against xcb-proto ; it needs needs to be compiled against version 1.5 or higher

Update xcb-proto to version 1.5 and probably rebuild libxcb with the new xcb-proto in use, please.
Comment 1 Bug Zapper 2009-06-09 13:07:42 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Michal Nowak 2009-07-13 09:48:09 EDT
Since xcb-proto-1.5 is in Rawhide, libxcb update to 1.3 does the job for me.
Comment 3 Adam Jackson 2009-07-20 17:00:37 EDT
libxcb-1.3-1.fc12                         dist-f12              ajax

closing.

Note You need to log in before you can comment on or make changes to this bug.