Bug 504286 - yum.Errors.RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: fedora-source. Please verify its path and try again
yum.Errors.RepoError: Cannot retrieve repository metadata (repomd.xml) for re...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-05 09:01 EDT by Michal Nowak
Modified: 2014-01-21 18:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 12:38:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2009-06-05 09:01:54 EDT
Description of problem:
newman@dhcp-lab-124 SRPMS $ yumdownloader --source xcb-proto
Loaded plugins: dellsysidplugin2, presto, refresh-packagekit
Enabling rpmfusion-nonfree-updates-testing-source repository
rpmfusion-nonfree-updates-testing-source    | 2.7 kB     00:00     
rpmfusion-nonfree-updates-testing-source/pr | 2.2 kB     00:00     
Enabling updates-testing-source repository
updates-testing-source/metalink             |  13 kB     00:00     
updates-testing-source                      | 2.9 kB     00:00     
updates-testing-source/primary_db           | 111 kB     00:00     
Enabling rpmfusion-nonfree-updates-source repository
rpmfusion-nonfree-updates-source            | 2.7 kB     00:00     
rpmfusion-nonfree-updates-source/primary_db | 1.1 kB     00:00     
Enabling updates-source repository
updates-source/metalink                     |  14 kB     00:00     
updates-source                              | 2.9 kB     00:00     
updates-source/primary_db                   | 229 kB     00:00     
Enabling rpmfusion-nonfree-source repository
rpmfusion-nonfree-source                    | 2.7 kB     00:00     
rpmfusion-nonfree-source/primary_db         |  32 kB     00:00     
Enabling rpmfusion-free-updates-source repository
rpmfusion-free-updates-source               | 2.7 kB     00:00     
rpmfusion-free-updates-source/primary_db    | 1.1 kB     00:00     
Enabling rpmfusion-free-updates-testing-source repository
rpmfusion-free-updates-testing-source       | 2.7 kB     00:00     
rpmfusion-free-updates-testing-source/prima | 4.5 kB     00:00     
Enabling fedora-source repository
fedora-source/metalink                      | 5.0 kB     00:00     
http://mirror.karneval.cz/pub/linux/fedora/linux/releases/11/Everything/source/SRPMS/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://ftp.fi.muni.cz/pub/linux/fedora/linux/releases/11/Everything/source/SRPMS/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://ftp.linux.cz/pub/linux/fedora/linux/releases/11/Everything/source/SRPMS/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
ftp://ftp6.linux.cz/pub/linux/fedora/linux/releases/11/Everything/source/SRPMS/repodata/repomd.xml: [Errno 4] IOError: <urlopen error [Errno -2] Name or service not known>
Trying other mirror.
http://ftp.nluug.nl/pub/os/Linux/distr/fedora/linux/releases/11/Everything/source/SRPMS/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://ftp-stud.hs-esslingen.de/pub/fedora/linux/releases/11/Everything/source/SRPMS/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://mirrors.nl.eu.kernel.org/fedora/releases/11/Everything/source/SRPMS/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://mirrors.se.eu.kernel.org/fedora/releases/11/Everything/source/SRPMS/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://ftp.upjs.sk/pub/fedora/linux/releases/11/Everything/source/SRPMS/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 315, in <module>
    util = YumDownloader()
  File "/usr/bin/yumdownloader", line 50, in __init__
    self.main()
  File "/usr/bin/yumdownloader", line 85, in main
    self.setupSourceRepos()
  File "/usr/bin/yumdownloader", line 125, in setupSourceRepos
    self._getSacks(archlist=archlist, thisrepo=repo.id)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 491, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 260, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 162, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 220, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1178, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1342, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1338, in _getRepoXML
    raise Errors.RepoError, msg
yum.Errors.RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: fedora-source. Please verify its path and try again

newman@dhcp-lab-124 SRPMS $ yum info xcb-proto
Loaded plugins: dellsysidplugin2, presto, refresh-packagekit
Available Packages
Name       : xcb-proto
Arch       : noarch
Version    : 1.4
Release    : 2.fc11
Size       : 70 k
Repo       : fedora
Summary    : XCB protocol descriptions
URL        : http://xcb.freedesktop.org/
License    : MIT
Description: XCB is a project to enable efficient language bindings to the X11 protocol.
           : This package contains the protocol descriptions themselves.  Language
           : bindings use these protocol descriptions to generate code for marshalling
           : the protocol.


Version-Release number of selected component (if applicable):

yum-utils-1.1.22-1.fc11.noarch
yum-3.2.23-3.fc11.noarch

How reproducible:

always

Actual results:

bt

Expected results:

xcb-proto srpm downloaded

Additional info:

Similar to RHEL5 bug 496674?
Comment 1 Michal Nowak 2009-06-05 09:03:27 EDT
Works OK under root.
Comment 2 James Antill 2009-06-05 10:03:58 EDT
You mean it works if you run it as root?

Does it work as the user if you "yum clean all" and then try again?

The above looks like mirroring problems, and given: https://www.redhat.com/archives/fedora-test-list/2009-June/msg00250.html

...I wonder if it's really a yum bug.
Comment 3 Michal Nowak 2009-06-08 05:04:13 EDT
(In reply to comment #2)
> You mean it works if you run it as root?

Yes.

> Does it work as the user if you "yum clean all" and then try again?

Nope. The traceback is the same.

> The above looks like mirroring problems, and given:
> https://www.redhat.com/archives/fedora-test-list/2009-June/msg00250.html
> 
> ...I wonder if it's really a yum bug.  

I guess - something other than traceback could be done, right?

Now what I can see:

newman@dhcp-lab-124 devel $ sudo yumdownloader --source xcb-proto
Loaded plugins: dellsysidplugin2, presto, refresh-packagekit
fedora/metalink                                                                                                                                                                                            | 7.1 kB     00:00     
http://ftp.fi.muni.cz/pub/linux/fedora/linux/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://ftp.linux.cz/pub/linux/fedora/linux/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
ftp://ftp6.linux.cz/pub/linux/fedora/linux/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 4] IOError: <urlopen error [Errno -2] Name or service not known>
Trying other mirror.
http://mirror.karneval.cz/pub/linux/fedora/linux/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://ftp.upjs.sk/pub/fedora/linux/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://mirrors.nl.eu.kernel.org/fedora/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://ftp-stud.hs-esslingen.de/pub/fedora/linux/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
ftp://alviss.et.tudelft.nl/pub/fedora/linux/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 4] IOError: <urlopen error ftp error: 550 Failed to change directory.>
Trying other mirror.
http://ftp.nluug.nl/pub/os/Linux/distr/fedora/linux/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://mirrors.se.eu.kernel.org/fedora/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://mirrors.vexs.net/pub/fedora/linux/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://mirror.arlug.ro/pub/fedora/linux/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://ftp.astral.ro/mirrors/fedora/pub/fedora/linux/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://fedora.nano-box.net/linux/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
http://ftp.informatik.uni-frankfurt.de/fedora/releases/11/Everything/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again


The srpm is not downloaded but the traceback is not present, I think I am quite happy with this traceback-less output. I'd expect the same when ran as user.
Comment 4 James Antill 2009-06-08 11:09:30 EDT
 Ok, I think this patch fixes it:

http://yum.baseurl.org/gitweb?p=yum-utils.git;a=commitdiff;h=8798ef15c2728e5e31c341519947482415c7d8ab

...it's not to do with user vs. root, but with normal repos. vs. source repos.
Comment 5 Michal Nowak 2009-06-08 11:19:44 EDT
Just tested, it's fixed. Thanks!
Comment 6 Bug Zapper 2009-06-09 13:07:57 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Lee Taylor 2009-08-31 09:45:33 EDT
yum -d9 list updates
Not loading "blacklist" plugin, as it is disabled
Loading "dellsysidplugin2" plugin
Loading "fastestmirror" plugin
Loading "presto" plugin
Loading "protectbase" plugin
Loading "refresh-packagekit" plugin
Not loading "whiteout" plugin, as it is disabled
Running "config" handler for "presto" plugin
Running "config" handler for "protectbase" plugin
Running "postconfig" handler for "dellsysidplugin2" plugin
Config time: 0.331
Running "init" handler for "dellsysidplugin2" plugin
Running "init" handler for "fastestmirror" plugin
Yum Version: 3.2.23
COMMAND: yum -d9 list updates 
Installroot: /
Ext Commands:

   updates
Setting up Package Sacks
Running "postreposetup" handler for "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * livna: rpm.livna.org
 * rpmfusion-free: download1.rpmfusion.org
 * rpmfusion-free-updates: download1.rpmfusion.org
 * rpmfusion-nonfree: download1.rpmfusion.org
 * rpmfusion-nonfree-updates: download1.rpmfusion.org
http://www.dfm.uninsubria.it/compiz/fusion-testing/qbittorrent/11/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: qbittorrent. Please verify its path and try again
[root@localhost ~]# nl /etc/yum.conf /etc/yum.repos.d/fedora.repo
     1	[main]
     2	cachedir=/var/cache/yum
     3	keepcache=0
     4	debuglevel=2
     5	logfile=/var/log/yum.log
     6	exactarch=1
     7	obsoletes=1
     8	gpgcheck=1
     9	plugins=1
    10	installonly_limit=3
       
    11	#  This is the default, if you make this bigger yum won't see if the metadata
    12	# is newer on the remote and so you'll "gain" the bandwidth of not having to
    13	# download the new metadata and "pay" for it by yum not having correct
    14	# information.
    15	#  It is esp. important, to have correct metadata, for distributions like
    16	# Fedora which don't keep old packages around. If you don't like this checking
    17	# interupting your command line usage, it's much better to have something
    18	# manually check the metadata once an hour (yum-updatesd will do this).
    19	# metadata_expire=90m
       
    20	# PUT YOUR REPOS HERE OR IN separate files named file.repo
    21	# in /etc/yum.repos.d
    22	[fedora]
    23	protect=yes
    24	name=Fedora $releasever - $basearch
    25	failovermethod=priority
    26	baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
    27	#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch
    28	enabled=1
    29	gpgcheck=1
    30	gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
       
    31	[fedora-debuginfo]
    32	protect=yes
    33	name=Fedora $releasever - $basearch - Debug
    34	failovermethod=priority
    35	baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/debug/
    36	#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-debug-$releasever&arch=$basearch
    37	enabled=0
    38	gpgcheck=1
    39	gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
       
    40	[fedora-source]
    41	protect=yes
    42	name=Fedora $releasever - Source
    43	failovermethod=priority
    44	baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/source/SRPMS/
    45	#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-source-$releasever&arch=$basearch
    46	enabled=0
    47	gpgcheck=1
    48	gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch
Comment 8 Lee Taylor 2009-08-31 09:58:38 EDT
fixed it. went to /etc/yum.repos.d and removed qbittorrent.repo

Note You need to log in before you can comment on or make changes to this bug.