Bug 504291 - Support automatic recognition of fence/resource agents using XML metadata
Support automatic recognition of fence/resource agents using XML metadata
Status: CLOSED DUPLICATE of bug 504290
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ryan McCabe
:
Depends On: 504290 724978
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-05 09:23 EDT by Perry Myers
Modified: 2011-07-22 09:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 504290
Environment:
Last Closed: 2010-01-11 11:27:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2009-06-05 09:23:38 EDT
+++ This bug was initially created as a clone of Bug #504290 +++

Description of problem:
Presently Conga (luci) requires code changes to support new resource or fence agents.  It would be better if luci read the XML metadata associated with these agents and dynamically constructed the interfaces in the UI for them so that adding new agents would just require a re-read of metadata rather than code changes.  Complex agents might still require code changes, but simple agents could be added dynamically.

This bug might require XML metadata to be added to the existing set of fence_agents, if so a new bug should be filed against cman/fence_agents and this bug should depend on that.
Comment 1 RHEL Product and Program Management 2009-06-05 10:06:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Ryan McCabe 2010-01-11 11:27:32 EST

*** This bug has been marked as a duplicate of bug 504290 ***

Note You need to log in before you can comment on or make changes to this bug.