This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 504295 - rhn_check outputs "Loaded plugins: rhnplugin" [NEEDINFO]
rhn_check outputs "Loaded plugins: rhnplugin"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Miroslav Suchý
Pavel Kralik
: Regression, Reopened
Depends On:
Blocks: 500798
  Show dependency treegraph
 
Reported: 2009-06-05 09:33 EDT by Jan Hutař
Modified: 2014-01-21 01:13 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:43:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
psklenar: needinfo?


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2009-06-05 09:33:38 EDT
Description of problem:
rhn_check outputs "Loaded plugins: rhnplugin"


Version-Release number of selected component (if applicable):
rhn-check-0.4.20-5.el5


How reproducible:
always


Steps to Reproduce:
1. # rhn_check


Actual results:
# rhn_check
Loaded plugins: rhnplugin
# rhn_check -vvv
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Providename rdonly mode=0x0
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
Loaded plugins: rhnplugin
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: opening  db index       /var/lib/rpm/Providename rdonly mode=0x0
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: May free Score board((nil))
D: login(forceUpdate=False) invoked
D: readCachedLogin invoked
D: Checking pickled loginInfo, currentTime= 1244208729.0 , createTime= 1244208528.02 , expire-offset= 3600.0
D: readCachedLogin(): using pickled loginInfo set to expire at  1244212128.02
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: May free Score board((nil))


Expected results:
no "Loaded plugins: rhnplugin" output when in silent mode (I mean without "-v" option(s))
Comment 10 Miroslav Suchý 2009-11-02 04:45:54 EST
OK. The lines where the messege is put on output is in:
 /usr/lib/python2.4/site-packages/yum/plugins.py
around line 210
This file belongs to yum. Reassign to yum component.
I suggest to lower default debug level or raise level of this one debug message.
Comment 11 James Antill 2009-11-02 17:03:54 EST
 yum-3.0.1-5.el5 has this:

        self.verbose_logger.log(logginglevels.INFO_2, 'Loading "%s" plugin', mod
name)

...so it certainly isn't a regression from the yum side, we always printed something.
 Why can't rhn_check drop the debuglevel itself (you can even require the latest yum and use preconf, to make it really easy)?
Comment 17 Jan Pazdziora 2009-12-07 08:22:38 EST
Fixed in Spacewalk master, 8d915a17b46d5e83a1b06d60b51c0e7ed36bf714.

Fixed in svn trunk:
Sending        actions/packages.py
Transmitting file data .
Committed revision 189257.

The fix consists of using the debug level from up2date / rhn_check command-line -v[v[v[v[v]]]] option for yum operations as well.

The change will appear in the yum-rhn-plugin package.
Comment 19 Pavel Kralik 2010-01-26 12:26:38 EST
Passed on RHEL5-Server-U4 (i386, x86_64, s390x) for the old and new version.
It worked as expected.

yum-rhn-plugin-0.5.4-15.el5 fixes the bug.
Comment 22 Petr Sklenar 2010-02-09 09:02:09 EST
hello,
I run rhn_check and there is no "Loaded plugins: rhnplugin" but some output is still there:

[root@qa-psklenar ~]# rhn_check
Package spacewalk-koan-0.1.11-13.el5sat.noarch already installed and latest version
- looking for Cobbler at http://satellite-1.brq.redhat.com/cobbler_api
- reading URL: http://satellite-1.brq.redhat.com/cblr/svc/op/ks/system/qa-psklenar.brq.redhat.com:1:kvm-guest-base-x86_64-1-SEE-2
install_tree: http://satellite-1.brq.redhat.com/ty/9JfJGKcT
libvirtd (pid  3884) is running...
- using qemu hypervisor, type=kvm
libvir: QEMU error : Domain not found: no domain with matching name 'kvm-guest-base-x86_64-1-SEE-2'
- adding disk: /var/lib/libvirt/images/kvm-guest-base-x86_64-1-SEE-2 of size 10
libvir: QEMU error : Domain not found: no domain with matching uuid 'P�*��������
libvir: QEMU error : Domain not found: no domain with matching name 'kvm-guest-base-x86_64-1-SEE-2'
use virt-manager and connect to qemu to manage guest: kvm-guest-base-x86_64-1-SEE-2
- polling for virt completion
- install is still running, sleeping for 1 minute (0)
...
--
Is it expected in no verbose mode , without "-v"
yum-rhn-plugin-0.5.4-15.el5
rhn-check-0.4.20-9.el5
Comment 23 errata-xmlrpc 2010-03-30 04:43:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0269.html

Note You need to log in before you can comment on or make changes to this bug.