Bug 504332 - Attempting to run wdaemon -a will not work on a tabletPC, even if a USB tablet is also connected
Attempting to run wdaemon -a will not work on a tabletPC, even if a USB table...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: wdaemon (Show other bugs)
5.4
All Linux
high Severity medium
: rc
: ---
Assigned To: Aristeu Rozanski
desktop-bugs@redhat.com
: Desktop, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-05 11:47 EDT by Suzanne Hillman
Modified: 2011-01-13 18:50 EST (History)
5 users (show)

See Also:
Fixed In Version: wdaemon-0.14-7
Doc Type: Bug Fix
Doc Text:
On a tablet PC that is detected as a tablet by wdaemon, the presence of a serial tablet caused the "wacom -a" command to fail with the following error: Error retrieving device id: Invalid argument With this update, an upstream patch has been applied to correct the detection of such device, and running the above command now produces the expected results.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 18:50:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backported patch, upstream revision 119 (1.97 KB, patch)
2009-06-09 12:15 EDT, Aristeu Rozanski
no flags Details | Diff

  None (edit)
Description Suzanne Hillman 2009-06-05 11:47:52 EDT
Description of problem:
If you are on a tabletPC that is correctly detected as a tablet (which is now fixed as of 5.4!), and have also connected a USB tablet, wacom -a will fail because it gets confused by the serial tablet. This _should still work_; it should just ignore the one it cannot use. It will appear to be a regression to a user, if it does not.

Version-Release number of selected component (if applicable):
wdaemon-0.14.2

How reproducible:
Always

Steps to Reproduce:
1. Get a tabletPC that works with linuxwacom (such as the toshiba portege), and make sure that it has an entry in /dev/input/wacom-tablets/[serial-[something], probably].
2. Connect a USB tablet that linuxwacom correctly detects (check that it has an entry in /dev/input/wacom-tablets/[tablet-name]).
3. Run "wdaemon -a".
  
Actual results:
"wdaemon version 0.14
device = 6,/dev/input/wacom-tablets/graphire4-4x5
Error retrieving device id: Invalid argument
Error opening /dev/input/wacom-tablets/serial-WACf004"

Expected results:
Should just print out the graphire4 line (there is also a fasttrack bug about the wdaemon version number; shouldn't that be in RHEL5.4?).

Additional info:
This is not precisely a regression. It did not previously happen because tabletPCs were not previously given the relevant link. However, it may appear as if it were a regression to a user who had previously been able to use wdaemon with a USB tablet on this machine. For this reason, it gets the regression keyword.
Comment 7 Aristeu Rozanski 2009-06-09 12:15:59 EDT
Created attachment 347052 [details]
backported patch, upstream revision 119
Comment 18 Ludek Smid 2010-03-11 07:23:42 EST
Since it is too late to address this issue in RHEL 5.5, it has been proposed for RHEL 5.6.  Contact your support representative if you need to escalate this issue.
Comment 27 Michael Boisvert 2010-12-02 12:12:36 EST
Bug tested in RHEL5.6 with wdaemon-0.14-7 installed on Toshiba Portege and Wacom Cintiq 21UX2. Running wdaemon -a wrote the proper config file without stopping prematurely because of the serial tablet interfering. The device was properly configured and the bug fix was successful. Verified.
Comment 28 Jaromir Hradilek 2010-12-17 09:47:52 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
On a tablet PC that is detected as a tablet by wdaemon, the presence of a serial tablet caused the "wacom -a" command to fail with the following error:

  Error retrieving device id: Invalid argument

With this update, an upstream patch has been applied to correct the detection of such device, and running the above command now produces the expected results.
Comment 30 errata-xmlrpc 2011-01-13 18:50:10 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0128.html

Note You need to log in before you can comment on or make changes to this bug.