Bug 504525 - /usr/kerberos/sbin not in user $PATH
/usr/kerberos/sbin not in user $PATH
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: krb5 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-07 17:16 EDT by Bernie Innocenti
Modified: 2009-06-08 11:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 11:21:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernie Innocenti 2009-06-07 17:16:00 EDT
Since Fedora 10, we reintroduced /sbin in non-root
user's path.

For consistency, /etc/profile.d/krb5-workstation.sh should
be modified to unconditionally add /usr/kerberos/sbin in PATH

Better yet, the whole /usr/kerberos hierarchy could be folded
in /usr like was done with /usr/X11R6.
Comment 1 Nalin Dahyabhai 2009-06-08 11:21:24 EDT
We can't fold all of it in because of duplicate filenames in the "bin" directory.

Kerberos's rsh actually falls back to exec()ing /usr/bin/rsh if it fails to establish a connection to the Kerberos rshd, and it doesn't implement the traditional rsh protocol (which requires that the app be setuid) so it's not a direct replacement.   This might change if the conflicting stuff gets split out in 1.8 or later, at which point tools which conflict name-wise could stay where they are while the rest of the krb5 package moves entirely to /usr, but that's not an option yet.

Putting /usr/kerberos/sbin in the path for everyone starting with 1.7-1.

Note You need to log in before you can comment on or make changes to this bug.