Bug 504536 - CTRL-Z and connect does not trigger heartbeat
CTRL-Z and connect does not trigger heartbeat
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1
All Linux
medium Severity medium
: 1.1.2
: ---
Assigned To: Carl Trieloff
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-07 21:43 EDT by Carl Trieloff
Modified: 2015-11-15 19:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 13:39:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for issue (747 bytes, patch)
2009-06-07 21:46 EDT, Carl Trieloff
no flags Details | Diff
Extra patch for closing connection (519 bytes, patch)
2009-06-22 23:08 EDT, Andrew Stitcher
no flags Details | Diff

  None (edit)
Description Carl Trieloff 2009-06-07 21:43:25 EDT
To reproduce,

./qpidd --auth no 
Then CTRL -Z
./latencytest --rate 10 --heartbeat 1

it should respond with connection closed. If latencytest does not get the
connection closed then the bug still exists.
Comment 1 Carl Trieloff 2009-06-07 21:46:25 EDT
Created attachment 346797 [details]
fix for issue
Comment 2 Carl Trieloff 2009-06-07 22:06:54 EDT
Testing the following also needs to be done to close the BZ

- start 2 brokers
- CNTRL-Z one of them
- connect with a failover subscriber, passing URL's for both nodes, the CNTRL-Z 'ed broker as the first one in the string
- check that the listner fails over and connects to the second broker.

if it connects to the second broker, the issue is resolve
Comment 3 Gordon Sim 2009-06-09 04:25:54 EDT
Fixed in qpidc-0.5.752581-13.el5
Comment 4 Frantisek Reznicek 2009-06-09 12:15:49 EDT
The issue has been fixed, validated on RHEL 4.7 / 5.3 i386 / x86_64 on packages qpid*-0.5.752581-13.el* and qpid*-0.5.752581-14.el5.

Note: Both parts verified (#0, #2).

->VERIFIED
Comment 6 errata-xmlrpc 2009-06-12 13:39:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1097.html
Comment 7 Andrew Stitcher 2009-06-22 23:08:51 EDT
Created attachment 349032 [details]
Extra patch for closing connection

Note You need to log in before you can comment on or make changes to this bug.