Bug 504552 - Nokia N73 doesnt want to talk on usb, gives error 110
Nokia N73 doesnt want to talk on usb, gives error 110
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-08 04:01 EDT by Jure Pečar
Modified: 2013-11-12 22:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 22:18:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jure Pečar 2009-06-08 04:01:07 EDT
Description of problem:
I have a Nokia N73 lying around wihch I want to use to send alert smses from our monitoring system to admins. Previously the phone was doing the job fine on a debian machine with gnokii, so I have a working config. On RedHat 5.3 however, same phone with same gnokii config doesn't work.


Version-Release number of selected component (if applicable):
kernel 2.6.18-128.1.6.el5
udev udev-095-14.19.el5
gnokii-0.6.27-2.el5
Anything else relevant?

How reproducible:
always


Steps to Reproduce:
1. plug phone into usb
2. try to send sms with gnokii
3. observe messages

  
Actual results:

gnokii says:

GNOKII Version 0.6.27
Couldn't read /root/.gnokiirc config file.
Couldn't read /root/.gnokiirc config file.
LOG: debug mask is 0x1
Config read from file /etc/gnokiirc.
phone instance config:
model = AT
port = /dev/ttyACM0
connection = serial
initlength = default
serial_baudrate = 115200
serial_write_usleep = -1
handshake = software
require_dcd = 0
smsc_timeout = 10
rfcomm_channel = 0
sm_retry = 0
Initializing AT capable mobile phone ...
Serial device: opening device /dev/ttyACM0
Gnokii serial_open: open: No such file or directory
Couldn't open ATBUS device: No such file or directory
AT bus initialization failed (1)
Initialization failed (1)
Serial device: closing device
Telephone interface init failed: Command failed.
Quitting.
Cannot unlock device.
Command failed.

from messages:
kernel: ohci_hcd 0000:00:0f.2: wakeup
kernel: usb 1-3: new full speed USB device using ohci_hcd and address 2
kernel: usb 1-3: configuration #1 chosen from 1 choice
kernel: cdc_acm 1-3:1.8: ttyACM0: USB ACM device
kernel: usbcore: registered new driver cdc_acm
kernel: drivers/usb/class/cdc-acm.c: v0.25:USB Abstract Control Model driver for USB modems and ISDN adapters
kernel: usbcore: registered new driver cdc_ether
kernel: rndis_host 1-3:1.10: RNDIS init failed, -32
kernel: rndis_host: probe of 1-3:1.10 failed with error -32
kernel: usbcore: registered new driver rndis_host
kernel: usb 1-3: USB disconnect, address 2
kernel: usb 1-3: new full speed USB device using ohci_hcd and address 3
kernel: ohci_hcd 0000:00:0f.2: wakeup
kernel: usb 1-3: new full speed USB device using ohci_hcd and address 4
kernel: usb 1-3: device not accepting address 4, error -110
kernel: ohci_hcd 0000:00:0f.2: wakeup
kernel: usb 1-3: new full speed USB device using ohci_hcd and address 6
kernel: usb 1-3: configuration #1 chosen from 1 choice
kernel: cdc_acm 1-3:1.8: ttyACM0: USB ACM device
kernel: rndis_host 1-3:1.10: RNDIS init failed, -32
kernel: rndis_host: probe of 1-3:1.10 failed with error -32
etc.

Expected results:
phone should get configured with ttyACM0 serial port accessible and gnokii should be able to send messages over it.


Additional info:
Debian box that the phone was previously on also runs kernel 2.6.18, namely 2.6.18-6-686. If they don't have some special tweaks to their usb, I suspect they do some magic in udev.
Googling for this error hints that the cause might be mixup of ohci and ehci. RHEL seems to load all three by default. How do I force only one to load?
Machine is HP DL360G3, lspci shows 00:0f.2 USB Controller: Broadcom OSB4/CSB5 OHCI USB Controller (rev 05).
Comment 1 John Feeney 2013-11-12 22:18:01 EST
This Bugzilla has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore is being closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide a sufficient business justification
in order to re-open it.

Note You need to log in before you can comment on or make changes to this bug.