Bug 504563 - Firefox crashes during folder selection
Firefox crashes during folder selection
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-08 04:27 EDT by Martin Stransky
Modified: 2009-09-29 06:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-29 06:37:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (8.20 KB, text/plain)
2009-06-08 04:29 EDT, Martin Stransky
no flags Details

  None (edit)
Description Martin Stransky 2009-06-08 04:27:58 EDT
Description of problem:

Firefox crashes in print dialog during folder selection

Version-Release number of selected component (if applicable):
3.5b4

How reproducible:
always

Steps to Reproduce:
1.run firefox
2.print
3.select print to file
4.select "Desktop" target folder
Comment 1 Martin Stransky 2009-06-08 04:29:55 EDT
Created attachment 346836 [details]
backtrace
Comment 2 Martin Stransky 2009-06-08 04:30:37 EDT
Note - It's fedora only. Unable to reproduce with official mozilla binary.
Comment 3 Martin Stransky 2009-06-08 04:31:57 EDT
Looks like the table at frame 0 is already released:

(gdb) p* table
$1 = {ops = 0xa5a5a5a5,	data = 0xa5a5a5a5, hashShift = -23131, maxAlphaFrac = 165 '¥', minAlphaFrac = 165 '¥', 
  entrySize = 0, entryCount = 2779096485, removedCount = 2779096485, generation = 2779096485, 
  entryStore = 0xa5a5a5a5 <Address 0xa5a5a5a5 out of bounds>}
Comment 4 Bug Zapper 2009-06-09 13:12:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Martin Stransky 2009-09-29 06:37:52 EDT
Hm, unable to reproduce any more....closing.

Note You need to log in before you can comment on or make changes to this bug.