Bug 504568 - pppoe/eth0 does not work
pppoe/eth0 does not work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-08 05:33 EDT by Arne Woerner
Modified: 2009-11-18 08:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-18 08:34:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arne Woerner 2009-06-08 05:33:28 EDT
Description of problem:
Today i tried kernel-2.6.29.4-75 from the updates-testing repo, because:
i wanted to c, if 503287 persists there:
https://bugzilla.redhat.com/show_bug.cgi?id=503287#c4
Then i saw, that pppoe said:
Jun  8 07:27:59 vaako pppoe[2355]: Timeout waiting for PADO packets
my ethernet card is onboard of an Asrock, ALiveDual-eSATA2:
Jun  8 07:27:11 vaako kernel: eth0: RTL8168b/8111b at 0xffffc20010a7a000,
00:19:66:5a:cd:ea, XID 38000000 IRQ 43
(the IRQ is different from 2.6.27.21-170.2.56.fc10.x86_64:
there it is IRQ 35:
Jun  8 07:39:02 vaako kernel: eth0: RTL8168b/8111b at 0xffffc20000334000, 00:19:66:5a:cd:ea, XID 38000000 IRQ 35)

Version-Release number of selected component (if applicable):
2.6.29.4-75

How reproducible:
i just tried it once

Steps to Reproduce:
1. reboot
2. bring up the ppp device
  
Actual results:
ppp gave up and exited after some attempts

Expected results:
there should have been an internet connection

Additional info:
that happened already some years ago (i forgot the kernel version)...
Comment 1 Arne Woerner 2009-06-08 06:26:59 EDT
i tried it again
and
it failed again...

and again the IRQ was different...

-arne
Comment 2 Arne Woerner 2009-06-10 08:05:47 EDT
fc11's kernel from the amd64 dvd doesnt support my eth0/pppoe, too... -arne
Comment 3 Chuck Ebbert 2009-06-11 16:13:44 EDT
Adding 'pci=nomsi' to the kernel boot options should fix this. Can you confirm that?
Comment 4 Arne Woerner 2009-06-12 06:05:03 EDT
yup!
w00t

now it works as before...:
> uname -a
Linux vaako.riddick.homeunix.org 2.6.29.4-75.fc10.x86_64 #1 SMP Mon May 25 15:45:14 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
> /sbin/ifconfig ppp0
ppp0      Link encap:Point-to-Point Protocol  
          inet addr:***  P-t-P:***  Mask:255.255.255.255

do i need a BIOS upgrade?

-arne
Comment 5 Chuck Ebbert 2009-06-12 19:15:02 EDT
The fix for this is in 2.6.29.5.
Comment 6 Arne Woerner 2009-06-20 05:23:18 EDT
hm - i installed it...

BUT: it still needs "pci=nomsi"...

why?

-arne
Comment 7 Bug Zapper 2009-11-18 07:05:05 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Arne Woerner 2009-11-18 08:34:02 EST
works fine with "pci=nomsi"... -arne

Note You need to log in before you can comment on or make changes to this bug.