Bug 504666 - When using iscsi ifaces with different initiator names only the default name is used for discovery
When using iscsi ifaces with different initiator names only the default name ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Mike Christie
Red Hat Kernel QE team
:
Depends On:
Blocks: 557926
  Show dependency treegraph
 
Reported: 2009-06-08 14:25 EDT by Mike Christie
Modified: 2010-10-23 05:59 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:57:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Christie 2009-06-08 14:25:33 EDT
Description of problem:

If you have multiple ifaces and each has a different iname, when doing sendtargets discovery the default name (/etc/iscsi/initiatorname.iscsi) is used instead of the iname in the iface.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Mike Christie 2009-06-08 14:35:33 EDT
Here is a workaround in case the fix for this does make it into 5.4. You only
need this if your discovery ACLs use the initiatorname and you are setting
those ACLs based on the iface initiatorname and not the name in
/etc/iscsi/initiatorname.iscsi.

1. Create your ifaces with the initiatorname (iname) you want to use.
2. Edit /etc/iscsi/initiatorname.iscsi with one of the inames.
3. Run the discovery command and pass in the iface for the iname that is being
used in step 2

iscsiadm -m discovery -t st -p ip -I ifaceX

(note: I am passing in the "-o new" argument since I just want to add new
portals and iface bindings).

4. Edit /etc/iscsi/initiatorname.iscsi again and add another one of the ifaces
inames.

5.  Run the discovery command again, and pass in the iface for the iname that
is being used in step 4, and also pass in the "-o new" argument:

iscsiadm -m discovery -t st -p ip -I ifaceX

(note: I am passing in the "-o new" argument since I just want to add new
portals and iface bindings and I do not want to remove the ones that were
created in #3).

6. Repeat #4 and %5 for each iface
Comment 4 Mike Christie 2009-12-22 01:49:20 EST
You can download the new rpm here:
http://people.redhat.com/mchristi/iscsi/rhel5.5/iscsi-initiator-utils/
Comment 8 errata-xmlrpc 2010-03-30 04:57:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0293.html

Note You need to log in before you can comment on or make changes to this bug.